does gimp support pressure sensitivity?

Hi, I have just bought a tablet and it is AWESOME!!! it works with every program I have, except for gimp. I mean it works fine but it doesn’t seem to register pressure sensitivity, is there a way to enable that or does gimp just doesn’t support it?
btw, I’m running gimp 2.8

You have to set what’s controlled by the pressure, a bit like in Blender.
Check the brush dynamics for each of your painting tools in GIMP

I know there was in 2.6 as I used to use it, since upgrading to 2.8 though I no longer have my tablet so cant really help… but if its not there yet then im certain it will be in 2.9

also what tablet have you got?

I had a similar problem last I tried using GIMP. I was using a Monoprice tablet (pretty decent actually except that I got a model without hotkeys which is slightly less good than I’d like).

Moved from “Misc > Off-topic Chat” to “Support > Other Software”

pressure sensitivity works fine with latest gimp and my wacom intuos 4m . Bare in mind that the website warns that pressure sensitivity does not work for all tablets. For example pressure did not work with older gimps and my wacom graphire. So its a hit or miss situation.

Also bare in mind that it will not work out of the box , you have to go inside prefereces and setup your tablet to be used by gimp and that assumers you have the latest drives installed and gimp actually supports your tablet.

hello, and thanks for the replies :smiley:

@bizla

also what tablet have you got?

I got a Monoprice talblet, you can get it from here: http://www.monoprice.com/products/product.asp?c_id=108&cp_id=10841&cs_id=1084102&p_id=6814&seq=1&format=2

and about the dynamics, I know that it used to work in 2.6 but now it doesn’t let me change anything


do yo u guys know the reason why this is happening?

have you turned it on in user preferences?

… oops :stuck_out_tongue:
now it’s working, with one small problem. The cursor that draws and the actual cursor are now apart from each other, if that makes sense:P

Just put it in pen mode.

make new dynamic settings in panel on right also you need to enable tablet everytime you run gimp, its a bug in 2.8 and devs know about it, version 2.6 works right from the start without all those problems

i know what you mean, i had this problem when i first used my tablet with gimp. if you go into edit> preferences and select the input options and select tablet, the dialogue box has a setting in the right hand panel, I set this to screen and it solved the issue.

i hope that procedure i said is correct my gimp is currently on a different hard drive so i’m saying this from memory! if i find i’m wrong i’ll let you know once i have synced my files

[Never mind the below–it seems that all you have to do is plug the tablet in before launching 2.8, then open and close the Input Devices menu and you’re all set.]

All,
I know this is a bit outdated (the last post was in October), but I’ve stumbled on a different, although more troublesome, way to enable pressure sensitivity in GIMP 2.8:

  1. Plug tablet in.
  2. Launch 2.6 (in this case I was using 2.6.12)
  3. Go to File > Preferences > Input Devices > Configure Extended Input Devices…
    a. If you get an error saying no input devices found, close 2.6 and relaunch.
  4. Draw something on the canvas using the tablet.
  5. Close 2.6
  6. Launch 2.8

You should now be able to draw in 2.8 with full pressure sensitivity. I’m not sure why this works, but I’ve tried it, rebooted my computer and tried it again with success. I am using Windows 8, but I believe it should work on all versions of Windows. Because OSX used X11 for 2.6, but not for 2.8 I’m unsure if this process would work.

Using Ubuntu 12.04 I was able to get 2.8 to handle pressure sensitivity right out of the box–but it could have been because I had just launched & closed 2.6 and had both installed side-by-side.

Like I said, this is a bit more cumbersome than the solution 2blackbar suggested above but I figured it was worth sharing.