Dope sheet question



Why is it that when i select all, those 4 keyframes dont move?

It says that there’s keyframes there, but under that group (turtle armatureAction) there’s no keyframes for any of the bones - nothing. Also, (in the last picture) I have nothing selected, in the viewport or the dopesheet, and those 4 keyframe remain “selected” (orange). I’m lost.

Edit:
https://developer.blender.org/T65211
“They appear selected because you are using a filter rot (top left). If you remove the filter you can see (and deselect all keyframes).” ----- What is this referring to?

2nd Edit: I can’t delete those keyframes either.

Linked file might get you the answer.

I believe the bug report is talking about that the reporter has used the filter dropdown on the dope sheet to filter by the text string “rot”, presumably to show only rotation registrations.

1 Like

https://drive.google.com/file/d/1Fg4ZqSn19fW2Ewg7S6PApOBqcnW36vUb/view?usp=sharing

to reproduce what i’m talking about, select all keyframes under “turtle armature” and just move them to the right/left, and you should see 4 keyframes remaining. (frame 60, 80, 100, and 120)

Thank you for the suggestion!

Looks like there are some keyframes on bones that aren’t on enabled bone layers. If you select your armature and enable the display of all bone layers (properties/object data/skeleton) all of these keyframes will move.

Not totally sure why it’s showing you these keyframes but not letting you edit them, not sure about the philosophy behind that decision or even if there was a philosophy, but that’s what you gotta do to edit them.

1 Like

https://drive.google.com/file/d/1l6SUSlHiJGEwVh2TqtP8gxDAxhzIwN-i/view?usp=sharing

I’m getting the same problem again, except this time when i activate all the layers of the rig and look in the dope sheet, nothing’s there. If you select all the key frames for the rig and move them to the right, you see that there’s still a bunch of key frames under the “turtle armatureAction” channel, but they don’t correspond to bones and the keyframes can’t be deleted. I’m very confused :confused:

Edit: i figured it out. i didn’t have the root bone selected :face_with_hand_over_mouth: :expressionless: :nerd_face: :flushed: