Dupli-Frames light movement

I’m having a problem using “Duplication” to position lights along a NurbsPath.
I’ve selected the light, and on the “Relations” panel selected the path.
On the “Dupication” panel I’ve selected:
Start: 1
End: 100
On: 1
Off: 4
And unchecked “Speed”

So far so good.
The lights appear along the path at the correct interval, and render fine.
But if I run the animation the first light goes zooming along the path.
I don’t want any lights to move in the animation.

What am I doing wrong?


I think something’s wrong there as dupliframing any other object will just hide it on render… looks like a bug to me. Anyway you could apply duplicates with Ctrl+A and then delete or hide light…

If you check “Speed” on the "Dupliction panel then you get the first light zooming along the path in the animation.

If you un-check “Speed” then you get the duplicate lights all visible the way they should be on every frame, but you still get the first light zooming along the path.

Hmmm…If only you could apply modifiers to lights and use an array instead of this method.

I’ve never used this method before, so I’m not sure if this is a bug or not.

You are correct, about Ctrl+A and then “Make Duplicates Real.” But there must be a better way.

Dupliframes with a lamp seems to be working OK for me. Perhaps you should check to see if you have a F-curve for Evaluation time on your path

Evaluation time?
I’ve set, on the “Relations” panel, the path as the “Parent” and I’ve set the “Duplication” panel to “Frames.” I have no keyframes on my lamp. Where do you set “Evaluation time” using this method ?

Evaluation time is on the path. Select the path and look in the Graph Editor and see if there is an F-curve present. The reason I suggested this is because if an object is parented to the path using Ctl-P and selecting follow path then a F-curve for evaluation time is set on the path. If dupliframes are added to this path you will get the dupliframes plus the object moving along the path.

AlanK, you got it.
I see the problem now.
I’m using the curve to place lights along a path, and spacing them using the values I mentioned on the “Duplication” panel for the light.

Apparently, even though I didn’t set any keyframes for the “Evaluation Time” there is an F-Curve automatically created. I tried inserting keyframes to override this, but you can’t.

Hmmm…how then do I stop the light from moving through the scene without using Ctrl+A and then “Make Duplicates Real” ?

I’d like to preserve editablity, as well as the option of animating the curve itself.
All this would be unnecessary if we could just add modifiers to lights.

In the Graph Editor, select the Evaluation Time F-curve and delete it (X). You should still have your dupliframes but the lamp will not move during animation.

That’s the ticket.
It’s so easy when you know what to do.
I got confused by the fact that there were no keyframes set, so I didn’t even look in the graph editor. Also, I’ve never seen F-Curves automatically generated like that before.