DupliGroup: hair particles not rendering

Hello everyone!

I have this following problem:

I created a tree, whose leaves were made using hair particle systems. Now - I added all of the parts of the tree into a new group and duplicated the group with a bunch of empty objects using the DupliGroup option. In the 3D view, everything looks fine, but when I try to render, my tree “clones” don’t have any leaves, whereas the original tree looks fine.

P.S.: I tried to make a simple .blend file with a single cube-shaped hair particle system, which I then added into a group and duplicated with empty objects and it showed the same behaviour - out of four hairy cubes, only the original one appeared in the render.

P.P.S: Maybe, I’m missing something essential, but that’s what these forums are for, right?

P.P.P.S: Will post the .blend file on demand, but the problem shouldn’t be hard to replicate. I’m working with Blender version 2.48a

Update:

I tried normal particle system (i.e. not hairs) and it behaves exactly the same. It seems that the duplicated particle systems DO render but the transformation of the group duplicators is not taken into account. If you look at the attached image, you will see that the original particle system without the duplicated objects looks more transparent than with them visible - that’s because there are actually more systems drawn over each other.

I presume that this is not an expected behavior (at least not for me). Should I file in a bug report? How?

Attachments


Another update: I just checked the 2.49a version and the problem is still there.

Bumpety-bump.

Did anyone else observe this behavior?

I hate to do this, but - bump.

This is a real problem for me. How else should I instance my tree leaves? Or maybe I’m asking in the wrong place?

I almost never use dupligroups, so I don’t entirely understand what you mean, can you upload a small blend file with the demo of your problem?

Hi, ZombieJohn!

Thank you for your interest :slight_smile:

I created a small blend file to show the problem. It has a single cube particle emitor that belongs to a group “Group”. That group is then duplicated (in the second layer, so you can turn the duplicates on and off to see my point) a few times. However, the particle system does not move with the duplicated groups, it stays in the centre.

Attachments

dupligroup_problem.blend (135 KB)

This is very interesting. The particles move with the cubes to get the effect you want, I think, in my version of blender, but ONLY IN THE 3D viewport. This sounds like a bug, to me. I’d attach this .blend file to a bug report at projects.blender.org.

That’s exactly how it behaves in my version too. Yeah, I already thought about filing a bugreport, but the tracking system was down yesterday. I’ll check it out again. It shouldn’t be hard to fix though - I think that a few lines of code that would transform the particle emitter correctly would suffice.

Edit: It’s done. I filed the bug. I’m curious now, how quickly (if at all :slight_smile: ) this will be resolved.

I work for a while with particles to simulation fountains and another water jet effects. My job these last days consist to prepare a library of differents kind of water jets.
Import as dupligroup works well and it is rather convenient. In the 3D viewport I can get many dupligroups with time offset working. But AARRG!! This does not render at all. The particles system seems to work well but something in the render pipeline is broken.
The problem persist in the 2.5.

bye bye

I see that I’m not alone with this problem. The bug report has now been unanswered for 2 months or so. I will probably try to fix this myself and send a patch to developers. :slight_smile:

Well, such a brave words you can’t hear every day! :smiley: So, cheers & good luck with it!

Did this ever get fixed? I’m trying to use duplicated particles now but they still don’t render.