Dyntopo Undo Loosing Work

I’m getting something weird with Dyntopo and undo.

  1. Happy times - I’m really enjoying Blender. It’s ace.
  2. Enter Dyntopo and get my sculpt on. Still awesome.
  3. I get a little too into it and select the wrong object and do something undesirable.
    No worries, I’ll just instinctively hit Ctrl-Z!
  4. Back to Square 1. I loose all my sculpting with no redo. <sweary time>

I’ve attached an illustrative image. It is 100% every time, but only in Dyntopo.

The obvious solution is “don’t do that,” but I still do it about twice a week (including just now). I’m pretty good at regular saves but still…

Is it just me? Is it a bug? Is there a better way? Am I missing something obvious?


your description of the problem was very confusing, for next time, dont try to be funny.

as for your problem, i cannot recall anything simular to me happening without me being able to undo it.
“It is 100% every time, but only in Dyntopo.” please provide a step by step description on how to recreate this problem, from a fresh blend scene, to where the problem occorres.

if possible, provide a blend file for us to start with where most of it is already set up.

Sorry, I sort of assumed it’s a known issue/annoyance as I have it both at home and at work for at least this version and the previous one.

  1. New File, I clicked Load factory settings, just in case I’ve got a dodgy startup file.

  2. We have a default cube already so draw a sphere. (OK, I’ve save this as a .blend and attached it.)

  3. Select Sphere.

  4. Sculpt Mode.

  5. Enable Dyntopo.

  6. Sculpt. [Screenshot 2]

  7. Right click the CUBE to select it. (The sphere is still in Sculpt Mode, but you select the cube as Object Mode)

  8. Move the CUBE. [Screenshot 3]

  9. Hit Ctrl-Z to undo.

  10. The Cube pops back to where it was and the sculpted sphere returns to it’s original form. [Screenshot 4]

  11. Try Ctrl-Shift-z to redo. The cube moves, but your sphere is still spherical.

Does that make sense?


dynoissue.blend (450 KB)

I just checked and it happens with the latest release. Makes no sense at all. Never had that problem before, and I usually work on several objects at the time… I think you should report a bug because it definitely shouldn’t be the expected behavior.

HATE blenders undo, luckily i learned to not use it, otherwise i would have unbound the key.

check your user preferences under editing, make sure the memory limit is 0 and global undo is ON.

what is there to hate? the undo works just like any other undo, you just have to mind the state of your object in which you preform the undo. in edit mode, you will undo to the previous state of the mesh. If you undo in object mode, you will jump to the last time you where in object mode.

Redoing your actions works just fine, just mind you that undoing in object mode, then entering edit mode will wipe the redo history. i see no reason for you to throw such anger at blender for something that is of noones fault than your own. after learning how blenders undo work, ive never messed up with it, and i feel completely safe using it.

i know how it works, but coming from the pampering of sketchups undo, its just too weird feeling. if say, it kept track of when you went into edit mode(or any mode), and made that part of the undo steps, it would be much nicer. then include placing the cursor as an undo step, and many other things would put it over the top.

yes it would be more memory consuming, but it would be worth it. especially for the newbies who press a random button, and the undo doesnt fix it.

Strange. If you switch to left-click select the issue is gone, as it is just not possible to select another object while in Sculpt mode… You have to switch to Object mode first and that seems to preserve the Dyntopo sculpting data.

I am having the same problem too. I also am usually pretty good at saves but sometimes you just forget and instinct kicks in. It’s happened with me a few times and I kick myself for being so stupid each time :smiley: There seems to be a similar old problem, I found this from the DevBlog from 2013 I think around v2.68, although it’s when you switch out to object mode first. The ideal thing would be just to undo the last stroke in sculpt mode, but instead it does a global undo and undoes the whole sculpt. I’m going to load up previous versions and see if it happens there.
Edit: You couldn’t select another object while in sculpt mode before 2.7 it seems so the issue only starts then.

i have this issue where pressing control z undo’s everything, until u trigger it back by clicking middle mouse button, movine or using a brush…its quite disruptive.