E+Z bug?


I use Blender 257.1 r36339 on Windows 7 Ultimate, CPU i7 core, RAM 6GB, NVIDIA GEFORCE with CUDA. For unknown reasons, E(Extrusion)+Z on 2 vertices or 1 edge does not produce a Z axis constraint extrusion as one would expect. On the contrary, E+X, E+Z both seem to work correctly.

It is reproduceable but should either be in the support section of the forum or better yet in the bugtracker.
I´ll check if it´s in there yet, might even be fixed already in svn. However I compiled svn yesterday and in that version it still appears to be broken. You got to press Z twice so it initializes the lock to Z.
And I guess in your last sentence you mean E+X, E+Y?

I looked into it again.
It seems that after extrude Blender already shows that the extrude is constrained to the YZ plane by showing the according axis.
Once you hit one of the keys to constrain to one axis, the constrain axis dissapear and Blender is in the expected state.
From there on it works as intended.

Didn´t find anything in the Bugtracker so far. Reporting.

oops! Yes, in my last sentence I meant E+X, E+Y. Sorry.

Thank you for your hint on pressing Z twice in order to make it work as expected. It’s easy once you know how to do it. However, maybe it’s a little bit unintuitive for some users (me included). Best would be that all the extrusions on one axis (E+X, E+Y, E+Z), for any number of vertices, edges and faces could work the same way.

Anyway, thank you for reporting this issue.

It is not a bug. I got into a discussion with Ton and Martin (theeth) and it´s actually working as intended.

If you press <e> to extrude, you are initially constrained. There are 3 modes of constraining in extruding.
off - global axis - user selected axis

When extruding an edge or two vertices, the user selected orientation is replaced with normal orientation and transformation is constrained to the plane perpendicular to that edge (locking normal Z), as such, it’s now at the “user selected axis” step in the cycle.

The constraint for <g> grab/move works different though. If you want it to work like you (and I) would expect it, you got to use “extude+move”. Press spacebar to bring up the menu and type “extrude” and see your options.

I don´t know where I would prefer a normal extrude over an extrude without a move, but as I posted in the tracker I never ran into it, but might at one point, because I usually cancel extrude with the right button and then <g>rab the new geometry and translate it into place.

Here´s my being slow on the uptake in the full version:

Hi arexma,

Thank you anyway so much for taking your time to inform the coders about this matter.
It is too much technical for me to understand your and their explaination in the bugtrucked thread.

Maybe, it could not be called a BUG but, from a user’s point of view, it’s awkward.

Anyway, for the time being, I will keep to rely upon your first precious information and I will hit Z twice to trigger the Z axis constraint.

Thank you again for you help,