Edge input node for compositor??

I am trying some toonlike rendering using the edge button in the blender internal render. When you look in the BSOD wiki page it shows the compositor with an input from “Edge” which looks like the edge outline generated in the render. But I cant find any inputs called edge or any ouputs from the render inputthat are edge in the compositor. How do I get hold of the edge render layer??

eg. http://wiki.blender.org/index.php/File:Manual-Renderlayer-Edge.jpg

Look at the options for the “Filter” node. There are a few edge settings there.

Disable all buttons (those in the same group) on the render layer tab except “Edge”.


I didn’t know that. Now I learned something, that’s gonna be helpful.

Thanks for the replies.

Rambobaby’s method works fine so I suppose that the manual doc uses a node that was eliminated, or more likely, the author was using this method and the name at the top of the input panel simply reflects what he named that render layer! LOL. BTW if anyone wants to try this remember to turn on sky or you won’t see anything in the render since the background and edge are black rendered on black; that threw me for a minute - oh its still there you just can’t see it.

To recap you make a new “render layer” in the scene selection of the render layers tab that has only edge selected in the row of layers and also make another render layer that has everything else selected and name it something else. When you use the compositor the render layer input node has a tab at the bottom that lets you select which of those “render layers” you want, you can have more than one of these inputs open in your compositor so you can fiddle to your hearts content.

Thanks The Bigfoot, but the edges I am talking about are outlines generated on top of your render to make it look “toonish” its a nifty option in the render buttons. Here is something I was able to put together for fun