Edge Nodes: Composite based edge detection

The setup:


Edge nodes takes the normal and z-pass, along with alpha and ob/mat indexes, and utilizes the already available filters within Blender’s composite node system-- Sobel, Laplace, etc.

This is not to replace Blender’s own “Edge” or the Freestyle branch by any means, just to give more options and compliment what already exists for line art.

This has been a collaborative venture between LightBWK, Daniel Kreuter, and myself.

Download the .blend here:

A post on how it works is here:

Please do experiment and abuse this setup, and please improve on it!

It works well on almost all cases, except on parallel normals.
That part we are still having problem.
The Z-pass solution is temporal.
Seeking better solutions.

Merry Christmas Blenderheads.
Edge nodes has Z depth fixed. A colorful fix.
Download version 1.1 >> http://db.tt/uxRy57Qf

I have just downloaded blend file from above link. ( EdgeNodesV1.1.Blend) and opened with Blender.265a
Added a UV Sphere and rendered. I got error

I just did what you said. Here is the result.

Is that the error you were saying?
If yes, you need to play with the nodes settings. [also read the post for guide]
This isn’t freestyle, everything depends on your mesh quality.

It renders, no problem and after that I get the error

Please show the error log, else we can’t help.

I have taken the screen short. Please see it. I have opened the file with Blender.265a and added a sphere
given a simple yellow color. Pressed F12. It rendered and just after the render I got the error. Before closing the Blender because of the error, I taken the screen shot.


I think Blender don’t have enough RAM to read the EXRs.
I have one old system that behaves just like that whenever I throw FSAA at it.
@patricia3d, how much RAM does your system have?

2 GB Ram Win XP

Super glitchy for me - Am I doing something wrong?

@piccobello, Nice render. XD /jk
What’s your setting?

@patricia3d, that confirms it.
You can’t use edge nodes as it should with so low RAM on Windows XP.
If you run Linux, I think, you still have a chance at 2GB of RAM.
Windows is RAM eating beast.

very useful, ty jikz

I have been playing with this for the last few days, and it is working really well. I am actually on Windows XP 32 bit with only 2 gigs of RAM and I’m not running out or crashing. I have been trying it with cycles, which has made some rather nice results (despite long render times.) The main issue I am encountering is that I am getting the occasional tiny black square scattered across the mesh (a makehuman model). They seem to be a single pixel in size. If I adjust various settings they go away, but then I get a different one somewhere else. I also get similar light gray boxes within the black outlines. These are all separate from cycles noise. It seems to work perfectly other than these and slight jaggedness from antialiasing.

Hail the maker of this node… it’s saving a lot of time rendering, meanwhile the result is almost similar to freestyle.