Edge select mode after adding multiple edge loops?

I’ve noticed that if you add multiple loop cuts whilst in vertex select that edge select mode is automatically selected. I find this quite annoying because I was in vertex select for a reason and why would adding multiple edge loops suddenly make edge select the best choice?

Does anyone know a way to turn off this quite annoying “feature”? I’ve had a look through the preferences but I can’t see anything obvious that would do this.

See here for further details (= fixed in latest build bot versions).

Oh, so it is a bug. Who would have thought.

Thanks for the reply.