Edges appear unjoined for displacement texture


I’m trying to follow this tutorial:

The model I tried it on was a basic cube. Experimental feature set enabled, subdivision modifier at 1, displacement set to True under materials. The edges of the cube appear to be unjoined when rendered. Also the Rendered Display view shows a very blotchy mesh. Can someone please help me figure out what I’m doing wrong? Thank you!

DEPTH-TEST4.blend (635 KB)

You should get used to doing a forum search beforehand, as both questions have been already asked quite a few times…

Set the shading of the cube to “Smooth” in order to keep the edges together.

Look at the Subsurf modifier: The dicing rate for preview is set to 8 px (vs. 1 px for the final render), hence the “washed-out” appearance. You can change that under Render > Geometry > Subdivision rate.

Thank you for your reply. I did try a search, but the keywords I tried didn’t match to what I was looking for.

Is smoothing the only way to resolve the gap? Eg, if I want a mesh to have a flat shading, is there another way to do this?