Edit Mode mouse cursor has changed into a crosshair

My normal arrow mouse cursor has somehow morphed into a crosshair, like a white + while in Edit Mode. No idea what happened, I was just modeling something and this new cursor has shown up. It works the same but I miss my arrow cursor. :frowning:

In object mode the curser is an arrow, in edit mode it is a cross. This is normal.

Not for me, until now it has always been an arrow. Here is a screenshot I have of before.

Don’t know if I have just been the victim of some weird bug until now or what…

Can you posts a screenshot of the cross curser

The cross cursor. It appeared during my current project (a door).

I am not sure with your system, yet the problem may be in defining your mouse cursor. I use windows and under control panel–>mouse–> there are options to change how your cursor will look in various modes. The + is used for precision select. It can be changed if you wish, yet I wonder why you would like it any different? Really, it is only an indicator of the mode you are in. See this:

Cheers, pix

in edit mode, select selection tool …click on it and drag it outside…now you will see different cursors and selection types …choose according to your ease.Thank you

Thread is 6 years old mate.

1 Like

And yet, I still found the answer useful. I guess it doesn’t matter when it is answered as long as it is useful.

I can’t do nothing :sob:

RIP :upside_down_face: