Editing post gives 502 bad gateway error

@bartv I tried to edit my first post in my addon thread, but when I click save, it gives me a 502 Bad Gateway error. Also if I refresh the page it shows me as having edited it, but not changing anything.
edit: I have tried clearing cookies and cache.
edit2: editing this post works.

Hmm, 502’s shouldn’t happen (often) anymore - they’re a sign of the server being overloaded. I don’t think we had any issues with that today - could you try re-editing it?

I have tried editing it 5 times now and the last time I tried to edit it was ~3 minutes ago. Is there another way to edit it other than the pencil button at the bottom (and top)?

No, the pencil icon is the only way.

Edit: works fine for me

It seems to be just that post, because edits here work fine.
Edit: this is the one that got migrated with a previous revision.

What’s the post URL?

I just made an edit on the first post there and it worked fine… Could you try again please?

Yep, one second.
edit: just tried, same error. Trying now in Chrome.

Which browser were you using?

Firefox 56.0.2 (64-bit)

Same error with Chrome. Could it be the content I’m trying to post?

No, I doubt it - I’ve tried that very same post both in Chrome and Firefox and have no problems editing it.

I’ve bumped your trust level to two, maybe that helps. Could you check again please?

That did it :smiley:

1 Like

Sounds like an edge case due to our import: your post probably included elements that require a higher trust level. On normal installations this wouldn’t occur.

I wonder if it’s because I include a zip as an attachment?

Not sure. I’m letting this rest for now, if this happens for more users we know what to do :slight_smile:

Thanks :slight_smile:

That is likely it.

1 Like