Eevee makes everything look dark

I wanted to render my scene using Eevee, as Cycles takes a very long time. For some reason everything in Eevee looks darker than it should and even if I increase the exposure, it doesn’t look very good as there is a very little difference between the dark areas and the bright ones. Here is a picture of the rendered scene (I should hide the plane, as it doesn’t get hidden by Eevee and Workbench, and only by Cycles, but you get what I mean):

A render with Workbench looks fine. Is there anything I can do to make the Eevee render look like something? (Also is there a way to make the render on Eevee cast a shadow on the plane without showing the plane itself?)

Do you have any lights in your scene? Doesn’t look like it

I have a light in my scene. It is just above the monkey.

Turn it up:

1 Like

It’s either too weak as @josephhansen shows,
or even disabled in the viewport:
image

2 Likes

It is already set to 1000W.

The scene light and scene world options are turned on.

Is it enabled?

And are you in Rendered view or Material Preview?

Yes, it is enabled and I am in rendered preview.

Here is the project file if you want to see it - https://drive.google.com/file/d/1r7MvkB1wd_SOC34r5jbbvJHo-ru_WXLS/view?usp=sharing
Also I am on version 2.93.8, in case that version has a bug.

Your scene looks exactly the same in Eevee or Cycles:


Ok, not exactly, but it looks nothing like what you have in your first post :thinking:

Ah yeah it might be a version thing. I tried it in 3.3 LTS

It seems that when I disable “Scene World” and set my own settings, it looks fine but does not persist when rendering to an image.

I tried it on Blender 3.3.1 and it looks the same.

I got nothing, your file worked for me, sorry

I downloaded a model and imported it and it worked with Eevee. The plane I placed before still appeared black.
Here is a picture of how that looks:
buggedeevee
Does this have anything to do with the materials? I had no materials on any of the models I used.

Edit: The Glossy shader works, but the Principled BSDF shader doesn’t work.

If that’s all you’re getting from a glossy shader, try moving your light closer

The image I posted has the plane material set to Principled BSDF and the robot set to Mix Shader with Glossy BSDF and Emission. Moving the light closer made a difference to the robot, but not to the plane.

What are the settings on the Principled BSDF?

They are set to the default.

I think your default has become corrupted somehow, that’s not what the principled BSDF defaults look like next to a glossy shader. You should have the same amount of specular as the robot, but rougher, and nearly twice as much diffuse