EEVEE Render black?

I paste some models from 2.79 into an EEVEE file
and I can see it in viewport
then I go into camera view and do an F12 rendr
but then I get time like 1 minute and black render image
scene is not there

I do have some sun light in the scene

what could cause this black render and how to correct it

happy cl

@RickyBlender Have you double checked the node editor to make sure everything converted correctly. I have had issues with bringing some models into EEVEE and just rendering. Some I had to almost set up the node tree all over again.

already check and all mat are there
but this is a very small scene and file is at 17 MB
why is this so big in EEVEE ?

happy cl

will try to do another set up file for EEVEE
with some lightprobes

and paste my scene into it then render it again
hope this time it works better
be back in one hour


happy bl

I do have one problem with box select
it refuses to select all objects
is there some parameters to change ?

happy cl

did a new EEVEE setup
I copied and paste all objects on windows to my new set up file

and when I press F12
after 10 seconds it crashes

tried 3 version of 2.8 and all crashes

can you make a test with this file here

EEVEE-Setup2.blend (295.8 KB)
happy bl

Once I get back to my computer I will give it a look.

it can render in lookdev and rendered mode
but not with F12 !

never had this problem before

I even tried to remove all objects in scene
and still crashing !

happy bl

With that file I get a whole bunch of error messages about stuff being missing. I can render with F12 and it shows me only this

Ok just tested it in an old 2.8 build and 2 others along with a custom build version I am beta testing for a guy and it crashed all of them. I will have to spend more time to find out the cause. Initially I thought it might have been the size of the render but after dropping it down to 1920x1080 it still crashed all of them. Not sure what the issue might be without having to go into it deeper and pick apart the file. But I also get a bunch of errors as well when opening it. Are you using any 3rd party add-ons that may not be compatible with 2.8 yet?

no Addon

but I did use the 2.79 Set up

I redid another manufacturer set up and seems to work with EEVEE!

darn I would hate to redo a new set up in 2.8 !


the render 2 post above is ok
how did you make it work ?

happy EEVEE

I simply hit F12. I’m using the 2.8 build from 26 May I think.

I tested 2 older version from 2 weeks ago and the one this weekend
and all crashes

have to try to redo a new set up file for 2.8

how where do you change the viewport Pan and rotate ?

also where do you select RMB or LMB ?

happy bl

I started a new set up file for 2.8
and re did test with my scene and still crashing

let me know if you can ID what is causing that crash
may have to do a bug report

happy bl

did another test
I appended all objects in a 2.8 file
and it seems to render well with F12

but if I try to append whole scene it does now work at all

happy bl

looks like there is a Bfont missing
might be the cause to crash !

any little script to change some font for another one ?

got the font but how do you get the font name ?
fnt =
print (’ font = ', fnt)

happy bl