Eevee Render Issues and Temporal Instability

So I’ve been testing Eevee to see if it is a viable alternative to cycles, and it appears to have temporal stability issues. Shadows swim, the screen space reflections flicker, and there are weird glitches in the camera animation. I uploaded the video here:

Does anyone have any tips on how to mitigate these problems? Is this a case of bad settings or is this just a byproduct of realtime rendering?


Perhaps the development being done in the Lightcache branch will help with the flickering?

Otherwise, I think part of the issue here is that additional measures would be needed to ensure temporal stability in a realtime scene (it doesn’t just happen out of the box like a new feature in a pathtracer).

Any idea what the Lightcache is meant to do, exactly?

The lightcache is mostly for the volume irradiance probes. it will allow you to save the baked lighting, instead of it recalculating every time you select something (Alpha software, I know)

It looks like most of the flickering lights are starting from the screen space reflections, and being amplified by the glare effect.

Have you unchecked the ‘Half Res Trace’ option for the ssr?

You could potentially try out the glare node in the compositor and see if that gets you better results than the real-time equivalent.

You could also try rendering it at a higher resolution with a wider lens, then cropping it to keep the screen space effects truly running to the edge, instead of fading out once it gets close to the edge.

Yeah, I unchecked half res trace, and the trace quality is set to 1. I had to set the thickness to 10m, because it was creating weird artefacts in the shadows at the default value. If there is a sweet spot when it comes to screen space reflections, I have yet to find it.

You could also try rendering it at a higher resolution with a wider lens, then cropping it to keep the screen space effects truly running to the edge, instead of fading out once it gets close to the edge

That’s an interesting idea, but it’s also flickering in the centre of the frame. See the rims, for instance. I’ll mess around with the settings and see if I can get it to behave a bit better. Cheers.

I spent the entire night running tests and I’ve come to the conclusion that there no are magic settings that make screen space reflections stable over multiple frames. This is a shame, because disabling it makes the image look like a scanline render from the 90’s. This gif shows the problem nicely.

Look at the rims, spoiler, headlights and glass.

Hi. I do not know anything about render engines like Eevee, and what I know about Eevee is mostly experimenting, trial and error. Do you know if it makes sense to use Screen Space Reflctions with Probes at the same time in this kind of engines? Or should one or the other be used, but not both at the same time?
Anyway, in animation I get some flickers in either of the ways without using volumetrics (Probes only or SSR only or combined), especially in highlights in glossy materials.

If this is not a problem of bad user configurations, I’m sure this will be improved by devs in the future.

Evee is not even alpha at this point so theres all kinds of glitches that make it pretty much unusable. On the latest build for example, the viewport makes a “second image” whenever I move the camera around. This is something that didnt happen before so I assume its just another bug that needs to be fixed.

Also the latest build crashes when I try to render in eeve.

I’ve been doing some tests, and at a higher Trace Quality I get more of the type of noise you show in the last image. Could you try with Trace Quality = 0.1 or 0.2 and see if you get less noise?
Also I get another type of noise of flashes and fireflies with Probes, so you for the moment avoid using Probes to better discover what causes the different types of noise that we see.

Hi, as of today 2.8, build today, doesnt “see” my GTX 760 anymore, 2.79 and Octane render fine on this Linux system.
Anybody have the same problem?

Cheers, mib

Hi mib. I can see my GTX 960 with Blender 2.8 built by myself today.

Interesting. It never occurred to me that lower quality settings might help things. :smirk: I’ll give it a try later on tonight.

Thanks for the info YAFU.
Buildbot from tonight is working so it is on my side, hrm.

Cheers, mib

For the record, my GPU hasn’t been recognised by 2.8 for a very long time, but it still seems to work perfectly fine. I don’t worry about it too much.

Anyone knows anything about how precise Eevee is? I often get random overlapping faces from it but not from cycles,OGL or any other renderer. Is there an option to manually set scene size bounding box (or epsilon) or how can i otherwise prevent this kind of issues (without touching geometry)?


sorry @mib2berlin these Reply buttons are too close to each other :wink:

Are we talking about Cycles right? What is your GPU?
In addition to selecting card from User Preferences > System, having switched to Cycles, you have to select GPU Compute from Render Tab, Performance item, Device (it has been moved there since a few days ago).

I’ve had a couple of that kind of problems, but I have not paid much attention to it. I remember the corkboard with pinned papers at the end of Classrom scene having that problem in Eevee (A modified scene in which I was testing eevee). But I’m sure that did not always happen, from some change/build it started to happen.

I guess this is a known problem for developers, but anyway you keep those scenes for when users can report problems.

I have also noticed that Eevee is more susceptible to generating visual distortions when some transformation is not correctly applied (compared to Cycles). You see if that could be your case.

I have problems rendering out Eevee. The only thing i see is a white/grey image without any lights and textures. Looks like a Depth pass. Seems to be like this since 2 weeks.
I wanted to upload a render tests to the Eevee demo thread.

Is it possible to share your .blend file?

No need to, i was just doing it wrong. :man_facepalming:
I was using OpenGL render instead of the normal render. It works, it did work the whole time.
But thanks man, your post triggered me to try it again.

BTW. Have your tried rendering your animation in 4K then scale it down to 1080p?
In my experience all kind of rendering artifacts get smaller and less visible when you have more pixels and then scale it down.
Its also a nice way to get very smooth anti-aliasing for every pixel on top of the integrated algorithm.