Eevee Rendering animation just keeps getting worse

Any body else notice that for animation Eevee just keeps getting worse?

per light softness - in 2.80 you could adjust the softness per light and it looks way better than turning on the option to have soft shadows. Soft shadows does not render in animations.

viewport rendering in 2.80 looks great and looks like the viewport… starting in 2.81 it never would work the same. Now I am trying viewport render in 2.82 and 2.83 and the color is totally different. If I use conventional render the color is ok but still no soft shadows.

Am I missing something?

Another issue that came up today. Blender does not update all the information before rendering a frame when rendering animation.

I have had this issue with hair in the past. The hair would behave in the viewport. But when rendering it doesn’t render correctly. For example, when you change frames on the timeline, you can see the image in the camera view update. When it updates to the frame, initially it will show an image but then that image updates again like a second later to display the hair dynamic. When rendering animations the image that comes out is the one before the hair dynamic update.

Now today I am getting similar issues with a rigged camera. The camera is parented to a bone and the bone is tracked to another bone. When I change frames in the timeline the same thing happens. Initially not everything will update at once. The camera rig updates like a second later. What comes out in render is before the rig updates and the camera angle is wrong.

Is there anybody out there with experience rendering animations with Eevee that has had a similar issue?

The camera is parented to a bone and the bone is tracked to another bone. (…) Initially not everything will update at once.

I can’t speak about past Eevee versions as I migrated straight from 2.79 to 2.82, but did you check the System Console for warnings when experiencing these update issues?

This description sounds an awful lot like dependency cycles, and in this case Eevee has nothing to do with it—you’ll see the same problem in Cycles.

When it updates to the frame, initially it will show an image but then that image updates again like a second later to display the hair dynamic.

If you’re using drivers check the emitter for invalid drivers.

Thanks. I am going to look into troubleshooting dependency cycles - something I was barely aware of.

I dont get any errors afaik but I have never even looked at the console! Im going to research that as well.

Glad to help. Some things only throw warnings in the console so it’s a good place to check when something is wrong—specially when dealing with dependency-related issues because these will only appear in the console. I’m talking about the System Console by the way, accessed through Window > Toggle System Console, to not be confused with the Console Area. :wink:

Usually it’s possible to tell an issue is dependency-related when things fail to update at the same time, keep bouncing between states, or update in a chaotic manner (like a bone pointing in a different direction every time you enter and exit edit mode).

For reference this is what a dependency cycle message looks like:


You can trigger this sort of error hitting Tab twice. You’ll know you successfully solved a dependency issue when you do this and no new warning pops up in the window.

Ok now I feel stupid… In my custom camera rig I had the focus bone tracking to the Camera bone and vice versa. The reason was so the focus bones custom shape would always face the camera. After some research it is now my understanding that the focus bone should have another bone parented to it and that bone has a copy rotation constraint. That bone is then used to override the custom shape transform of the focus bone.

Thanks for the tip about the console and edit mode trick. Thats good stuff. I had no idea. Maybe this could be used to trouble shoot my hair dilemma?

1 Like

There is was right in the console window like you said. Thanks again! I had no idea.

Now if I could get viewport rendering to stop changing the color. In 2.82 when I viewpoint render, its like it multiplies the color setting. Like in the viewport my high contrast setting looks good but then in viewport rendering seems like the high contrast is applied twice.

Check if this happens in a new scene. Things changing colors when rendering make me think of rogue settings, a compositor/world node issue or geometry/lights hidden in viewport but enabled in render. Also double check your Viewport settings, ensuring both Scene Lights and Scene World are enabled to get accurate previews.

I did create a new simple scene and the problem is still there. A single frame looks like the viewport. An animation the color is off.

I tried AVI jpeg, ffmpeg, and an image sequence of pngs. I also turned of the post processing in the render settings.

Isnt the whole point of viewport render to show exactly whats in the viewport?

I discovered that if I set the display device to “none” rather than “srgb” in the color management settings the viewport render will look the same as the viewport. But that makes the f12 render look way darker than the viewport. This is happening in 2.82a and the 2.83 version I downloaded yesterday.
In 2.80 both view port and f12 render look exactly like the viewport (as long as the render and viewport settings match as far as modifiers and object visibilty etc)

This kinda sucks because I did notice the newer versions were a lot snappier when using the interface… but whats the point if the viewport cant represent what the render will look like? Isnt that the whole point of eevee?

I’ve run some tests on 2.82 here and I’m not seeing what you’re describing. Can you share screenshots of the issue and your Color Management and Output settings? A .blend file with a test scene and all the exact Render settings you’re using would be ideal.

[Edited to add gif tests comparison]

Problem went away. I believe it was an outdated graphics driver.