Emission shader causing blown-out colors?

I have a chandelier in my scene, which is positioned in the center, and provides the majority of the light to the room. There is no natural light entering the room from outside.

The chandelier has six candle-style bulbs, which I’ve added an emission shader to. In order for my room to be bright enough, I’ve had to crank the strength of the emission shader up to 2000, and it’s causing the color in the candlesticks below the bulbs to be completely white and blown out, with no detail showing in them or the bulbs.

Example:


If anyone can tell me what I need to do to make sure my room gets enough light, while retaining the detail in the bulbs and candlesticks themselves, I would be incredibly grateful for any help you all may have to offer.

If you are using Blender 2.78 or higher, you can use the Filmic settings to keep all the detail in your renders, even with very strong lights. Go the the Scene tab in the Properties panel (it’s to the left of the world icon). In the Color Management section, change the Color Space to Filmic Log (and the View as well), and play around with the Look settings. I like to use High Contrast, but you may prefer something else.

use point lights and just make the candles 1 emission. thats also alot more efficient, especially when you use branched path tracing (uncheck “Sample all Indirect” for a speed boost).

filmic will help with color balance, but its not going to solve all your problems.

You can mix two emission shaders (one with strengh set to 2000, the other with strengh set to 1) with a Light Path node using the Is Camera Ray socket. By doing that, you tell Cycles to use the strengh 2000 emission shader to only light the room (not be visible to the camera) and the other emission shader to be visible to the camera.
The result is that your room gets enough light while the details on the light source are retained.

Attachments


True, but Filmic is not just a color balance tool. It’s really good at retaining detail when there is a bright light source since it provides a better dynamic range. It’s not going to make your images worse, so why not just have it on by default since sRGB is a terribly inaccurate color space anyway?

“With filmic blender you don’t really have to cheat like you were used to and you can use way more realistic values when it comes to setting up lights.” --Manuel Albert, Blendernation

Ah yes, I knew something was missing! I had completely forgotten to re-enable Filmic after moving to my new computer. Duh. Thanks! And yes, the Filmic look is worlds better than sRGB.

Hey, that’s a great idea! I always wondered if you could do something like that, I just never really messed with it myself. I just tried it out, and it actually turned out looking really nice. It seems to just have a lot more of a natural look to it, and I feel like I have more control over how much light actually gets into the scene. Thanks for the suggestion!

2000 strength for candles? That doesn’t make any sense. Put in reasonable values and adjust the scene exposure. What are your diffuse bounces set to? Also, in this case I think I would have faked it - candle light themselves only visible on glossy, and a separate much bigger point light set to diffuse only. It will help tons for noise levels on the diffuse which for me tends to be dominating. Finally, you may want to try the color/light falloff node, although I rarely get it to do what I need or think it does :stuck_out_tongue: