Enabling Transparency in the 3D View in 2.70

I’m trying to enable transparency in the 3D window in Object and Edit mode in 2.70. I have found this very handy for a variety of modeling tasks in 2.49 (see attached screen shots), but can’t get it to work in 2.70. I’m not sure whether I just don’t know how, or if it’s not implemented in 2.70.

I’ve added a mesh, applied a texture (with transparent areas), and UV mapped it. The transparency works in a Blender render, but not in the 3D view.

I’ve done the following:
Set the View Mode to Texture.
In the Outliner, the object has a mesh, the mesh has a texture, and the texture has a (partially transparent) image.
In Object Properties, Transparency is checked in the Display Panel.
In Object Data Properties, the UV Maps list shows the correct UV map name.
In Material Properties, in the Transparency panel Transparency is checked and set to Z Transparency and Alpha to 1.000.
In Material Properties, in the Options panel, Face Textures and Face Textures Alpha are checked.
In Texture Properties, in the Image panel, the source image is listed correctly, View as Rendered and View Alpha are checked, and Alpha is set to Straight.
In Texture Properties, in the Image Sampling panel, Use is checked under Alpha.
In Texture Properties, in the Mapping panel, Coordinates is set to UV and the correct UV map is listed.
In Texture Properties, in the Influence panel, under Diffuse, Color and Alpha are checked and set to 1.000.
Everything else is at its default setting.

If there is something I missed, I apologize, but would certainly like to know what it is.


Try to set in the N Panel under Shading from Multitexture to GLSL, possibly that could fix it for you.

Also, you need to turn the material Z transparency Alpha to 0 with the image texture set to affect Alpha at 1.

Craig, thank you! Although I tried switching to GLSL and setting the Z transparency alpha to values less than 1, I had not tried them both together. That combination, together with the other settings I listed, works perfectly! :slight_smile:

Good deal, hapopy blending!