Enigma of Ice Ice Baby (Fluid -> Domain)

So I was doing this tutorial (8.40 time) and decided to play a around a bit with my text. Instead of a single ICE word I decided to choose text Ice Ice Baby with one of I-s and y lying on the ground. All with melt effect. I have designed basic text as instructed, made 5 diferent text groups (one for I, one for ce, one for Ice, one for Bab and one for y), and initially have put around this tossed-around text one box to give it Physics -> Fluid -> Domain attributes. Well it had just grabbed all 5 text groups and mashed them together in one “Ice Ice Baby” straight line.

So I did five separate different boxes around these 5 different texts and when i tried to give Physics -> Fluid -> Domain attributes to the first box same thing happened - all 5 different texts were set up together as pic related.

You guys got any advice as how to set up this properly?


You can only have ONE fluid domain object in your scene
Ensure all the objects in your scene have a scale of 1. You can apply the scale to those that don’t with Ctrl+A
Also your domain scale is way too low and you are showing the even lower res preview value in the viewport. Best to change this to Final

You have not supplied any .blend file to review so we cannot check what may be also wrong

Thanks man. I’m still just testing the water regarding blender (as seen by my question) and I thought my intuitive upgrade of basic tutorial might work. Sometimes these things work really nice and sometimes i fail hard (as now) :stuck_out_tongue: If I attached file properly, It should be here:

IceIce3dDemolished.blend (919 KB)

After applying the scale for all objects (they don’t have a scale of 1) and setting the fluid viewport display to show the Final resolution I get:

The resolution of 200 is also pretty low for the result I expect you are looking for

If not too noobish questions:

You can only have ONE fluid domain object in your scene

So one should always have a single box with fluid ->domain properties?

Ensure all the objects in your scene have a scale of 1.

Ctrl + A brings me to a menu but … I did some relative Scaling (chosen object + S) so far and scaling along X, Y, Z axis but I think you say I should mark every object and in Object mode pick a specific size somewhere while in Scale mode? Mind telling me how do I do that?

Also your domain scale is way too low

As too small? Should be bigger cube?

and you are showing the even lower res preview value in the viewport. Best to change this to Final

So Resolution goes from 45 to 65 in this case.

Ok this is beyond silly. I started

(@ 8:16) and when I was to set up Fluid -> Domain, “Ice Ice Baby” popped out again somehow :smiley: Oh God! :smiley:

Attaching the file in hope of mystery being resolved by blender-competent and good soul here. Jeez. :smiley: paprike01.blend (571 KB)

Edit: Was messing around with this file (it was started as New project) and have deleted the Fluid->Domain cube, made a brand new one and when I assign Fluid->Domain, this text pops up again.

Halp? I’m afraid all my fluid tutorial attempts will be messed up with this. It feels a bit like if I was in Word and had copied a bunch of text once and now whenever I press Ctrl-V it pops up. Is this a bug? How should I get rid of it?

thanks :slight_smile:

So. A while ago I tried

and was messing around with text a bit. When I came to a point of picking a cube to define its properties as Fluid -> Domain it had somehow generated my text into “Ice Ice Baby” sequence.

Now this is happening with all tutorials where I apply “Fluid ->Domain” in them. (I tried

yesterday in the evening and same damn thing happened) Its beyond silly.

Anyone has any clue how to bring things back to normality? File is attached right after I applied Fluid -> Domain to cube and text from tutorial I did yesterday (Ice Ice Baby text) is somehow generated even if it does not resemble text that I wrote for this tutorial.


ICE.blend (697 KB)

Please, keep your stuff together
Thread: Fluid -> Domain messes up my text

Oh ok. It’s been a day and no solutions were offered to this problem, so I thought someone might notice a new thread. I’m seriously thinking of deleting all files plus reinstalling blender to get rid of this.

OK So I have wondered over here from my usual places on BA and seen your thread and did this:

I did change the End to 0.1 and the End Frame to 20; like he said on the tutorial, but I left the Resolution the same and it worked. So it’s your file on my Mac, maybe you have an issue on your machine that is not Blender related? I also deleted the initial fluid_cache directory, where the dynamics are stored, and did it again - same result. So can you post an image of what you are getting please?

Cheers, Clock.

I guess that’s the problem here.
The OP stores all his files into the same folder. Blender finds the previous fluid cache files in that folder and just uses those again because it can’t know those belong to a different fluid sim.

Hence the results of the first fluid simulation popping up again and again.

Good call Sir! I have just realised what you have said - it is ALWAYS called fluid_cache isn’t it…

Cheers, Clock.

Both threads merged.

Oh. My. God! Thanks so much guys.(and sorry to mr. Mod for spamming. And tnx for help before mr. Mod :))

I have just deleted all files, deleted render, reinstalled, made ICE tutorial again, tried to make something else after that and bam! ICE again.

And after reading the solution by IkariShinji … bazaam.

So happy. So basically I have to clear the cache_fluid every time i make a new project with water? This really messed me up because it would affect all tutorials with water but now I can proceede unhindered.

@Balor01 - all you have to do is put your projects in separate disk directories - that way each project can have its own fluid_cache directory… Or, you can simply specify the directory for the fluid_cache somewhere else and have different directories for each fluid_cache, this allows for multiple fluid sims in the same blender project…

Cheers, Clock.