Error code appears when trying to import SVG images

So i’m having problems when trying to import .SVG image files to Blender. Unfortunately i don’t speak this computer mumbo jumbo and i was hoping that someone on here could give me some help in order to fix this, hopefully as simplisticly explained to me so that i could understand this.

You should be able to see the problem with this link:

Hi @Artei, in order to see if the problem is the .svg file you’re trying to import here is a simple star.svg, made in Inkscape. I can import this into Blender 2.79 with no problem. If you can’t then the likely problem is the svg import add-on [ try removing it, close Blender, Open Blender install add-on again ]. If you CAN import my .svg file then the issue is in your .svg file - it’s not in a format that the Blender add-on knows how to deal with. In which case try opening your .svg in Inkscape or something similar and re-exporting. Here’s my star ( wow, it shows up as the actual image!)star because I can’t tell if this is downloadable I’ll update this message after I’ve posted it.

Update: It’s fine, just Right-click on the star and ‘save-as’, it comes in as an .svg though it will have a random name.

Hi @DamianJ . I tried to import that star image into Blender 2.79, but it was same as before,
just givin’ me the error code and not load up. I even tried to remove and re-install the io_curve_svg addon but nothing happened. So basically i’m back at square one.

Hi Ari. Have you tried importing it into Blender 2.8? ( this works for me) you will need to enable the addon as it is not on by default:-

If this works, but you want to use the shape in Blender 2.79 then save the 2.8 file somewhere temporary. Open 2.79 and from the Append menu:-


go to the 2.8 file you saved, into the Object sub-folder and select the curve object. This will be the geometry you want.

I suspect that your original .svg add-on may have become corrupted by something else. If it’s not a serious inconvenience you might want to consider ‘re-installing’ Blender as this add-on is built in.

What version of Blender 2.79 are you using exactly?
The SVG provided by @DamianJ imports just fine on my official Blender 2.79b (Win 10 Pro x64)…

Curious if anybody was able to resolve this, because I’m having the same issue as the OP.