Error Compiling Blender, Ubuntu 9.04 64

yasm -Iextern/xvidcore/src/image/x86_asm/ -I../../src/ -f elf64 -DMARK_FUNCS -DARCH_IS_X86_64 -o /home/gary/src/build/linux2/extern/xvidcore/src/image/x86_asm/colorspace_yuyv_mmx.o extern/xvidcore/src/image/x86_asm/colorspace_yuyv_mmx.asm
<b>yasm: FATAL: unable to open include file `'</b>
scons: *** [/home/gary/src/build/linux2/extern/xvidcore/src/image/x86_asm/colorspace_yuyv_mmx.o] Error 1
scons: building terminated because of errors.

Recently I’ve been able to build 2.49 with no problems. I’ve also tried building after a scons clean.

Same error on my opensuse 11/64.
Try this, work for me:
I read this in the #blendercoders chat, or disable ffmpeg in or in your

By mib

have you tried “scons clean” and then try rebuilding?

That worked, thank you!

Same problem here – Arch Linux, 64-bit. “scons clean” doesn’t work. Tried the above “” and it worked. Is there a “proper” fix for this?

if the compiling doesn’t work you could download here :

fix in post #2 also works on 32bit Jaunty.

If at all possible, I need to be able to compile Blender for things I present, etc. Using the info above:

cd blender/extern/xvidcore/src/
find . -type d -exec cp -v '{}' \;

I got it to compile. I guess I’m just wondering what changed in the last couple of weeks to make the build process break concerning ffmpeg. I assume that it will be fixed at some point, but I am just wondering. Someone somewhere has to be able to compile it on Linux, so I’m curious as to what they have changed or are doing. That’s all I was wondering about.