Error exporting uv map

Blender was working fine up until yesterday. I didn’t change anything on my computer.
But today whenever I try to export a uv layout I get this error:

What can be causing it? Thanks.

1 Like

Welcome to BA :slight_smile:
Have you tried running Blender as an administrator (right click on Blender, Run As Adminstrator)?

Thanks :slight_smile: Yes, I tried. But it didn’t work.

I’m just now noticing that you’re trying to save to a different drive… I swear there was a bug with that use case a few versions ago, are you using the most recent 3.3 release?

Is the image already opened in another program?


No, I’m using the 2.7 versions. I’m creating objects for The Sims, and only things created on the 2.7 versions work for the game.
Actually Blender was installed on F: drive, and I reinstalled it on C: to see if the problem would be fixed. Did I make it worst then? :sweat_smile:

Ok that’s probably why. Question- what do you mean by:

The Blender version shouldn’t affect your exports at all. If anything, 3.3 has better, less buggy, exporters than 2.7

Hello! No, it’s not. Actually I couldn’t even export it. I need the uv to be exported, because the texture has to be created in an image editor.

Ok, thank you. If anything, I’ll try to use the 3.3 to export the texture.
For some reason, to create content for The Sims 4, only objects created on the 2.70-2.79 work. Even if you create something on 2.8 (or above), you have to later open the object on a 2.7 version, save it and import it to a software called Sims4Studio. The meshes also have to be named “s4studio_mesh_(number)”, or it won’t work either. Kind of said though, since Blender is away beyond the 2.7 versions now.

1 Like

Wow, that’s really weird. You might be able to sneak a 3.3 blend file into this software- if you open a blender file in notepad, at the very beginning, you’ll see the version of Blender that created the file, you could try changing those numbers and see if it tricks the software

1 Like

Oh, I never thought of it. That’s very interesting. I can try it someday.
The weird thing is that, I just tried the 2.7 version again today and it exported the uv. Like, why/how? hah
I literally tried everything I could yesterday. Changed folders, reinstalled, restarted the computer and nothing. And today it simply works again. Maybe Blender was not in a good mood yesterday :sweat_smile:
Thank you so much for your help and tips. If it happens again, I’ll try the 3.3 version :slight_smile:

1 Like