Error installing 2.49a Installer & Zip (Windows xp)

Hello everybody,

A brief reading of blender minutes, to me suggests that perhaps the errors to both install attempts are the results of absence of python 2.6?

Please help


Not a lot to go on is there ?


an external python install shouldn’t be necessary. many python functions are compiled into the blender code, so you only need python installed separately if you want to use additional python functions.

Sorry to be so brief. I think the problem was with blender site. I was getting 2 different dll errors while I tried to download from the installer and the zip. Went back a few hours later and all is working.


Can you pleas tell me how do i install Python 2.6 in Blender. Coz when i open the program, that black screen behind Blender was unable to find the python, even though i have it in my computer. Can you tell me. Its Blender 2.49a 64-bit version. Thanx

i actually figured that out by overwriting it. Can you guys tell me, is it a good idea to overwrite Blenders python script with downloaded new version python script?

It’s a good idea if you get the scripts from a correctly updated site (svn’s blender\release\scripts folder or, for french users, the packed files from, for instance). Elsewhere, the scripts are often older than the ones in the zipped archives of the curreent released version.

If there is any possibility you could tell me what my problem is about, it’ll be perfect. I have put Luxrender’s Script in Blenders script. When i opened Blender i could see Luxrender Exporter, but the problem is, when i press it, it gives me a python error, and when i check the black screen that’s behind blenders window, it shows a SyntaxError: Invalid Syntax, and something like “File <“strdn” line 1” something like that. Pleas tell me the solution.

Try to work with a blender built with python 2.5.

there is no problem exporting to Luxrender using Python 2.5 or Python 2.6.
I know, I tested it.

I tried the zipped 2.49a from and use it without a complete python 2.6.2 installation :
the 2.6.2 file provided in the ptyhon…zip does not work as they should (like in the 2.48a)
import os or import random will fail…
will make some tests.

hey littleneo,
yes, you will find this is a known issue with the random module.
(i heard devs debating this recently.)
I didn’t pick up on it until it was mentioned

I’m on Windows xp & Vista, I have Python 2.5, 2.6 & 3.1.
That way there’s no issues with finding Python & all the modules are correct.
Hopefully this issue will be fixed in a bug release.
Really there should at least be a note on the download page that a full Python install may be needed to run some scripts.
This is why on the wiki pages I write that a full Python install is recommended.
To avoid confusion & errors.

thanks meta,

the os module seems broken also… everything’s ok with 2.6.2. installed
I tried to modify the with the original 2.6.2 files (I believe they are not the same) but blender complains about the zip format. tried also to add a path to a python26 folder, but it checks the zip first… what is the tool used to zip it ? tried different things with 7z but it failed)

…and I did this silly thing that works (at least with the city engine script), when no python 2.6.2 installed :

just copy the from the 2.49 install and paste/rename it in the 2.49a. :wink:
(that’s insane, I know) ( in fact)

hey littleneo, that’s a handy trick.
i would suggest taking a look at some builds from Graphicall.
Zebulon & Kai Kostack produce some good builds.
I think Zebulon has fixed the py26 zip, but I’m unsure.

I have a question, i got everything resolved in terms of software problems, BUT there is one thing that bothers me about working with fluids. I rendered a water scene with Subdivide and Smooth levels 2(you can already imagine rendering while those on can take forever, well mine took 10 hours, that’s not bad), and also i set the resolution to 430, but after baking i could still see some pixelation in the water. Than what i did after baking was, i Mulitiresed it to Level 4 and added subsurf modifier to level 3. But i still could see tiny bit of pixelation in the water. Do you think i should add more Multires and more subsurf levels? The thing is, if i can see tiny bit of pixelation at 1000x400, than higher pixel image would show more. I’m trying to make a high quality image, probably around 5000x3000 for illustration. Pleas tell me if there is any other ways to solve this problem. Thanx

Just use Set Smooth. In the Link and materials section in the Editing (F9) Panel.
All your multires and subsurf is way overkill to get a smooth surface. You must have a supercomputer to use those settings.


“You must have a supercomputer to use those settings.” That i definitely do have(of course i have to add more rams to render more faster for images), but i already did add set smooth, and also i did add more multires and subsurf to level 6 and 7. It did kind of get what i want, but then i realized my mistake was from the beginning. Yes i’ll still add the multires and subsurf after baking, but i forgot to bake it with more then level 2 smooth surface, so i can get smoother. For off topic question, do other 3d softwares have installation headaches like you would normally have with Blender. Don’t get me wrong, I f****ing love Blender, because you get the same professional quality as the other softwares that cost from $2000 to $8000. The reason why i’m asking this is, i’m starting to get really in to 3d illustrations and most studios require knowledge in the other softwares, and i’m thinking of get those softs, so what you think, basically it seems that this question is mostly for those who use the other softwares(Maya, Cinema 4d, 3D’s Max, XSI, etc.). Will i have the same installation problems like i had with Blender? Will i have headaches with installing external Rendering engines? Thanx

O and i almost forgot, do other softwares require installing python and stuff like that?

^^no, check your control panel. you most likely have 2.5 or nothing at all.

Download 2.6 so that in appears in your control panel. then restart blender.