Error with game engine publishing addon.

I am trying to export from windows to mac, I have downloaded the zip macosx blender file and extracted it. I set it as the library path, unchecked use default platform, set the blenderplayer path to the blenderplayer in the extracted zip file.

But when I try to publish it gives me the following error, I tried unchecking the “Relative Path” but it didn’t work.

I get this error:


I think you might have to click “make archive”

I tried but didn’t work.
I think the problem is that it looks for the “2.77” folder in the same directory as the player which is not true for the mac build of blender, It’s only true for the windows and linux build I think, not sure why its doing that or am I doing something wrong?

Hm… Not quite sure, as I use a mac and wouldn’t run into this problem.

That’s interesting, I’ve got the same error message and can’t publish


I just downloaded this .blend file and wanted to publish a standalone game file. It returned error as below.

how can it be fixed?



That’s just a packing problem, you probably moved all your source files or changed the location of your blend file.

Wooooooops ! The stupid thing I did… thnks for highlight… ! I will re-download and check it.

Thx for tip ! : ))


No I tried re-downoading the whole file from blendswap and tried to publish again. The error still blocks it.
Am i missing anything in blender to set ?

It says lots of files are missing but I guess thsy must have been packed in .blend itself !

Help plz.



Can you provide a link to the download…

yeah its here :

I am not sure if there is an easier way but there are data blocks of images to which paths cannot be found, you have to go into the UV image editor and find all the images whose paths are missing and press the ‘X’ button that says (unlink datablock) while holding shift. After that go to the outliner and select orphan data from dropdown menu and you should see all those images.

Save the blend file and open it again, they should all be gone and you should be able to export.

I could achieve it.

I had to unpack all textures and recompile the game file !

Thx for response friend !

Cheers !

Hello Wisaam, thanks for your instructions, that helped me solve the missing images problem for my file too.
Could also explain how to proceed with missing scripts?
I have a script which is missing, but that script is in use, so I cannot delete it. I don’t know why blender is reporting an error message.

It probably doesn’t matter since I am able to compile the game now.