Errored selection when selecting vertices (some CVS-builds)


(Falgor) #1

JUST SCROLL DOWN.

Have you ever had problem with selecting vertices?
Some blend-files just start bugging in some point of the work. When I try to select, lets say the right corner vertex of a box [Desoto taught me that “vertices” is many vertex(es)] but it selects the opposite corner vertex.

Like it selected the geometrically opposite vertex… Like it had flipped vertices (like flipped normals). If I zoom out more it works, but if I go a bit closer, it starts to select totally wrong vertices. Like pressing “1” from the keyboard and getting a “9”.

Anyone had this problem? I dont know what it could be, since the problem stays, even if I opened it in a different version of blender. I even sent it to a couple of guys at #blenderchat (lucidMonkey and jsplifer). They didnt have the problem with the blend-file.

Maybe my geometrical processor is crashing or z-buffer has gone haywire.

:Z


(z3r0 d) #2

any version you say?

[this only happens in solid mode with “clip selection to visible” turned on?]


(Falgor) #3

Actually, it seems my build (and other builds, versions) utterly lack the button for that function z3ro_d. But for example in 2.37, which has the button, , it works fine…
strange. Maybe I need a new build.


(Falgor) #4

Yeah, and it seems if I load this blend with “load UI” option enabled the button won’t appear even if the build had it. Got the latest TWEAK build. Works now if I dont load the UI.

I guess there was something wrong with the settings of that blend’s UI?
:expressionless: Or something.


(Falgor) #5

However… The problem comes again. I edit a couple of SECONDS, and it starts to… well for example, I try to select a vertice (vertex) in the head area of a horse, and I have zoomed the model so that the whole model isnt in the view…
Guess what happens? It selects a vertice (vertex) from somewhere between the legs of the horse. I think there is something wrong with the z-buffer or something. I really dont get this.

It’s like it select the “inverse” vertice (vertex) of the model if I zoom too close.It might be because I’m using fullscreen tweak… If anyone has had this problem, please reply.


(Falgor) #6

Here’s a clip I made about the problem.

http://koti.mbnet.fi/falgor/questroom/showhow/vertex-selection-error.avi

Check it out, please.

It happens in wire edit mode, only, I guess.


(Falgor) #7

It’s not just in the latest builds of Bellorum. It’s also in some of the first builds that had the “fluidsim” feature.
And also with the ones that didnt have fullscreen tweak. So it cannot be the fullscreen tweak’s fault.

HMMMM… Maybe we should call Sherlock. :Z