EWOCprojects: KnifePro0.5

After a week in hell debugging this little script, here it is (still bit buggy though).

A replacement for Blender’s native knife tool.

It allows cutting exactly through vertices, works through selecting cutting points ON the edge and cutting through your cut in one and the same operation.

Hope you like it…
…and some feedback please on which knife you think handles the best…

Don’t feed your ego, feed the duckies…

Hi paleajed, im getting an error:

Traceback (most recent call last):
  File "<string>", line 322, in ?
TypeError: sequence item 0: expected string, NoneType found

Im running it on a tuhopuu i built this morning. Its running on XP, any ideas?


Yep, I knew this would happen. I kind of rushed out the plugin, only supporting users that install it into their user script dir. As you might know Blender looks for scripts in both default and user script directories.

Whatever, I did what I should have done straight away and put an updated version 0.51 on the website, it now supports both script dirs.
(NOTE: Don’t forget to install both scripts.)

Havn’t tried it yet, but I am looking forward to using it.

Thanks for your suite of scripts. They are quite useful. :smiley:

EDIT: Ok, i just tried it but i get this error:

Traceback (most recent call last):
File “(string)”, line 327, in ?
AttributeError: ‘Nonetype’ object has no attribute ‘edges’

I might be doing something wrong, but it worked on the default cube when I tried it first. This is a more complex object. Any ideas?


Hmmm, as far as I can see you selected an empty object or any other object without any vertices/edges/faces. The error message means the object you selected doesn’t have any mesh data. Maybe it is a NURBS object (‘surface’) ? The script only works with polygon or subdivision (‘meshes’).

To be on the save side, try this: select exactly one object, press Tab to go into EditMode and then start the script. If it’s a polygon object, there will be no error. (at least not this error, I know the script ain’t perfect yet…)

Don’t feed your ego, feed the duckies…

Well, it was a mesh, and i tried it in both object mode with the mesh selected and in edit mode with and without the edges/vertices selected.

So, I don’t think that is it. I am not at home at the moment, but I will try it again, and if is still doesn’t work, I will see if I can send the file to you.

Aha, a strange mystery bug then it seems. :-?

And yes; if you could send me the file… would be greatly appreciated.
Just attach it to an email message and pop it over to [email protected] !

fakeplastic: the bug is found and destoyed, new version available

all: more bugs have been found, consider this script experimental

Thanks, I forgot about this. I haven’t had time to work on my project so it completely slipped my mind.

Thanks for this script and fixing the bugs. I really think this is a great addition.