EWOCprojects: KnifePro0.7

[!] Important update.

This powerful (I suppose :wink: ) alternative to Blender’s builtin knife tool evolves a bit further.

Changes since last version:

  • initialization speedup: waiting time on mesh with 8000 faces reduced from 29 to 0.6 seconds, making the script usable on all sizes of meshes now
  • general speedup during editing
  • user can now rotate/pan/zoom the view during operation using standard Blender controls
  • now works in perspective mode also
  • handles boundary of open meshes
  • while some bugs remain, this is the first stable release … (I hope )

Get it here:

More EWOCnews:
TranspRef is now at version 0.7.
It now works in perspective mode also.

Don’t feed your ego, feed the duckies…

I get this error with the latest build from blender.org:

“Traceback (most recent call last):
File “<string>”, line 425, in ?
AttributeError: text file not found”

Thanks for the bug report Caronte, I wouldn’t have spotted this one myself.

It was a simple problem when checking for the second script.

Bugfix release 0.71 on website now.

TranspRef0.7 has the same bug.

Again update 0.71 on site now.

I get now:

“Traceback (most recent call last):
File “<string>”, line 443, in ?
AttributeError: no such Blender Text.”

[!] New version 0.72 available. One major (viewport change only worked when model was centered on 0,0,0) and one small bug solved.

I get now:

“Traceback (most recent call last):
File “<string>”, line 443, in ?
AttributeError: no such Blender Text.”

Two possible answers:

  1. you did only install the file ‘KnifeProx.xx.py’ from the zip file. You must install ‘knifeproblade.py’ also. Copy both files into your script dir.

  2. more likely: by chance, I yesterday compiled a new Blender-CVS build and it seems there are strange problems with the script support. Blender doesn’t seem to recognize certain scripts in the script directory. The KnifePro script, although in the directory, doen’t show up in the “Mesh -> Scripts” menu. When I tried to load the script into a text editor and run it, I got the same error as you. To fix, I then went to script dir preferences (for those who don’t know, by pulling down the top window header and selecting “File Paths”(, then set your user script dir again (make sure both scripts are inside this directory) (set it even if it’s the same as before) and click on the “Re-evaluate scripts” button. Now run the KnifePro script from text editor and everything will be fine (well, it works here). If the script doesn’t register in the menus and you want it to, only fix I know is reverting back to an older CVS build. :frowning: If this trick doesn’t work, again, try an older build.

Hope this helps (no other ideas at the moment).
Let me know if it works.

Don’t feed your ego, feed the duckies…

I already set the path to scripts directory (in the info window), and that correct the problem.

Thanks, nice script like ever :wink: