Export to .svg (2.49b or 2.53)

Hey (my 1st post here) :wink:

I’m using the latest Blender build rigth now.
I just wanted to render a “Scalable Vector Graphic” (SVG).

But there isnt such an option in Blender 2.53 :frowning:
So I tried Blender 2.49b again.
In the “Scripts”-windows, there is a svg-export script.

But nothing happens when I click it.
Just an error pops up: Check your console …

(console says sth like: bla bla bla loading file “svgexport.py” bla bla bla filename=filename+".svg" bla bla bla TypeError: can only concatenate tuple (not “str” to tuple) bla bla bla)

I tried Pantograph before that - didn’t work either (tried out blender 2.44)…

Is there any ability to render a svg in 2.53 OR 2.49b?
(Im using Py v.2.6.2)
Id really need this right now to use with Inkscape…

(mh srry for my bad english, hope you guys know what i wanted to say…?)

Rendering to .svg is not possible. Render a .tga or .png and convert it in inkscape.

It is possible. (why else would there be an option for exporting svg’s in 2.49 and earlier?)
It just won’t work for some reason…:frowning:

I don’t have any option for exporting .svg, so perhaps it is a script you installed that is no longer supported by the version of Blender or Python you are using?

Can you show a screenshot of the option please, maybe someone will recognise it.

You still have the option to render the image and convert it to .svg externally, I’m sure it will look similar.

You can save (or is it Export?) UV’s in .svg.

I didn’t install any external scripts…
I just downloaded the official 2.49b Build from blender.org.
Two screenshots I made:

  1. showing the export option
  2. showing rendering engine for vector graphics

None of these currently work.
(again: I did not add any scripts!)

Hope you can help me…

Exporting UV’s works - But I want a full scalable render…

Ehm I just want to explain, why I want to export svg’s:
If Id use a (fe.) bitmap, Inkscape would pixelate the picture while zooming.
Hope that this doesnt happen when I export the pic directly from blender.
Hope you know what I mean :wink:


Pantograph, I believe was written for 2.45 and 2.48, so it may well be broken in 2.49.

There may be an update available, check which version you have:-

The scripts catalogue doesn’t show any .svg export bundled with 2.49. That doesn’t mean it isn’t, but I also checked the zip file for Windows and there doesn’t seem to be any .svg exporter. Is it installed with Pantograph? Is it possible your recent 2.49 install is reading from an older scripts folder?

Checking the scripts catalogue again, Pantograph is listed as ‘external’, and the vector rendering script page no longer exists:-

You could also try here for information/updates:-

The scripts catalogue doesn’t show any .svg export

Mh strange…
I now tested Pantograph with 2.44, 2.48 and 2.49b (on Win7 x64).
Didn’t work with any of these versions.

Anyway thanks very much for reply…
But it just won’t work:spin: