extrude acting funny.

I imported a ai file and it imported with no problems-- but when I tried to extrude it, it extruded horizontally instead of vertically? any ideas?

I also need the answer to this I have the same problem

There can be many reasons. I can’t get ai-files loaded, so I can’t test, but first check where are the coordinate axes of your object pointing, where are the normals pointing. You’ll find these on the buttons, put them visible for a moment. What if you try to rotate the imported object before you use it, or try to “apply scale and rotation” (you’ll find these on menu too)? What happens when you lock the extruding along the global coordinate axes, that is, press X Y or Z after pressing E to extrude? Try to press X Y or Z twice, does it make difference?

Try to use the 3D transform manipulator (the hand icon). You can first extrude with zero extrucion (that is, press E and Enter without moving the mouse), and grab the extruded area with manipulators.

And of course: Where is the pivot point? Have you changed it to 3D-cursor, or objects center?

I use SVG. Open up the AI file in Illustrator and do a Save As…In the file type drop down select SVG and accept the default.

Then import the SVG file into BLENDER. I generally import colors and click separate curves.

At this point you will have a bunch of curves with materials on each curve. Select a curve, press F9 and used the extrude controls to extrude your cruve.

try to do a Ctrl-A on the object this should reset the objecct;s axis to the global system’s axis


ctrl + a worked perfectly! thanks.