EZ Baker

The new 1.0.0 UI looks good. The settings are a lot more readable than before.

Currently there are two sections called settings: The settings tab, and then the Bakers>Settings tab. I would suggest naming one or the other something else.

Seems im unable to enable 1.0 on 2.90 and 2.91.

Traceback (most recent call last):
  File "C:\Program Files\Blender Foundation\Blender 2.90\2.90\scripts\modules\addon_utils.py", line 382, in enable
    mod.register()
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.90\scripts\addons\ez_baker\__init__.py", line 166, in register
    updater_ops.register(bl_info)
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.90\scripts\addons\ez_baker\addon_updater\ops.py", line 1490, in register
    bpy.utils.register_class(cls)
ValueError: register_class(...): already registered as a subclass 'addon_updater_install_popup'


1 Like

Ooo there’s a new Marmoset Toolbag option. Will try it! :smiley:

Strange, mine works well in 2.90. Try uninstall all versions and reinstall addon

Have done that already nothing. Even tried it with default blender still same error not sure what is causing it.

EDIT: looks like the problem could be from the fact i use a symlink addon folder though every other addon doesn’t have this issue when i use just a standard addon folder everything works.

EDIT2: looks like symlink is not the issue. will keep looking.

EDIT3: New Error,

Traceback (most recent call last):
  File "E:\Programs\blender\2.91\2.91\scripts\modules\addon_utils.py", line 382, in enable
    mod.register()
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\ez_baker-1_0_0\__init__.py", line 171, in register
    from . import core
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\ez_baker-1_0_0\core.py", line 16, in <module>
    from . import baker
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\ez_baker-1_0_0\baker.py", line 8, in <module>
    from . import devices
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\ez_baker-1_0_0\devices\__init__.py", line 2, in <module>
    from . import blender
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\ez_baker-1_0_0\devices\blender\__init__.py", line 17, in <module>
    from . import maps
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\ez_baker-1_0_0\devices\blender\maps\__init__.py", line 11, in <module>
    importlib.import_module('.' + i, package=__package__)
  File "E:\Programs\blender\2.91\2.91\python\lib\importlib\__init__.py", line 127, in import_module
    return _bootstrap._gcd_import(name[level:], package, level)
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\ez_baker-1_0_0\devices\blender\maps\map_uv_layout.py", line 8, in <module>
    from PIL import Image, ImageDraw
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\modules\PIL\Image.py", line 94, in <module>
    from . import _imaging as core
ImportError: cannot import name '_imaging' from 'PIL' (C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\modules\PIL\__init__.py)

EDIT4: Ez baker 2.0 works fine 3.0 and 1.0 not working.
First time install gets you top error when trying to install after the first time ever time i try to enable after it’s

Traceback (most recent call last):
  File "E:\Programs\blender\2.91\2.91\scripts\modules\addon_utils.py", line 382, in enable
    mod.register()
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\ez_baker-1_0_0\__init__.py", line 166, in register
    updater_ops.register(bl_info)
  File "C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\ez_baker-1_0_0\addon_updater\ops.py", line 1490, in register
    bpy.utils.register_class(cls)
ValueError: register_class(...): already registered as a subclass 'addon_updater_install_popup'


@Justo Good idea, I’ll probably rename them to global settings and baker settings

@Lamia updating the addon within blender and using symlink might produce errors.
I think I tried it once and it didn’t work. I’ve tried the addon in 2.90.1 and it’s working fine for me.
To fix the import error go to this file

C:\Users\{username}\AppData\Roaming\Blender Foundation\Blender\2.91\scripts\addons\ez_baker-1_0_0\devices\blender\maps\map_uv_layout.py

and add this at the bottom

except ImportError:
    pass

I’ll fix that for the next release

1 Like

That worked thanks!

1 Like

Peraphs it can help about baking speed and new texture types? AssetGen addon (old thread) specifically this part:

Thank you for this excellent tool, this is extremely useful ! Being able to bake both Blender-style and Toolbag-style maps is a huge time saver.

1 Like

It seems with marmoset from time to time i get an error when i press bake

Python: Traceback (most recent call last):
  File "C:\Users\{USER}\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\ez_baker-1_0_0\operators\op_bake.py", line 39, in execute
    baker.bake()
  File "C:\Users\{USER}\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\ez_baker-1_0_0\baker.py", line 232, in bake
    self.child_device.bake_multithread()
  File "C:\Users\{USER}\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\ez_baker-1_0_0\devices\marmoset\__init__.py", line 313, in bake_multithread
    device_datapath=self.path_from_id()
  File "E:\Programs\blender\2.92\2.92\scripts\modules\bpy\ops.py", line 132, in __call__
    ret = _op_call(self.idname_py(), None, kw)
RuntimeError: Error: Python: Traceback (most recent call last):
  File "C:\Users\{USER}\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\ez_baker-1_0_0\devices\marmoset\__init__.py", line 88, in execute
    connection = listener.accept()
  File "E:\Programs\blender\2.92\2.92\python\lib\multiprocessing\connection.py", line 453, in accept
    c = self._listener.accept()
  File "E:\Programs\blender\2.92\2.92\python\lib\multiprocessing\connection.py", line 598, in accept
    s, self._last_accepted = self._socket.accept()
  File "E:\Programs\blender\2.92\2.92\python\lib\socket.py", line 212, in accept
    fd, addr = self._accept()
socket.timeout: timed out

location: E:\Programs\blender\2.92\2.92\scripts\modules\bpy\ops.py:132



location: <unknown location>:-1

The only thing I can think of is increasing the timeout seconds in this file

"C:\Users\{USER}\AppData\Roaming\Blender Foundation\Blender\2.92\scripts\addons\ez_baker-1_0_0\devices\marmoset\__init__.py"

in line 87 you find this:

listener._listener._socket.settimeout(3)

change the 3 to a higher number, maybe 10 or 15, it means the seconds blender will wait for marmoset to respond
then restart blender and see if it helps

1 Like

That was 100% it, changed it to 5 seconds and now no more issues. Thanks so much! :slight_smile:

1 Like

I also think it might be an ok idea to have a check box in baker settings to keep the marmoset window open, there are some times where you want to use some of the marmoset tools to correct some bake issues.

Makes sense, I’ll take it into account for a future update

2 Likes