Face and vertices selection

Hello everyone :slight_smile:
I started to model in Blender a couple of days ago and i am now starting to get a little sense of it :slight_smile:

But still, i have a minor issues that REALLY piss me off - like selecting a certain face and vertices!

I know how to select them piece by piece, and with L and etc’ but i didnt managed to get those results.
Please, tell me, how can i select it in ONE click like in this pictures:

and here:

P.S - This was taken from Jonathan Williamson’s M4 guide. A nd in this guide he just selected the vertices and the face almost in 1 click.

Thank you very much!

In Edge or Vertices select mode, ALT + Right click on an edge will select all the edges+vertices from a loop.
In Face selection mode, ALT+Right click near the edge of a face will select all the faces from a loop in the direction the nearby edge was.

If you want to select a specific bunch of faces, edges or vertices, you can press B and make a selection over them.
Or if you want to select like if you were painting over the faces,press the C key and move the brush over the wanted faces, with the mousewheel you can adjust the brush size, right click to move out of this selection mode

When I try to select a connected row of vertices using this suggestion:

“In Edge or Vertices select mode, ALT + Right click on an edge will select all the edges+vertices from a loop.”

I get this dialogue:
Any idea what I’m doing wrong? Thanks in advance to all who reply…

ETA: this is in the 2.63RC1 Blender, and happens whether I use the right or left mouse button to select.

PosMatic: make sure that your video card isn’t forcing anti-aliasing on Blender, this can cause problems with selection.

Robynsveil: That looks like something that your os is doing and not Blender, try maximizing Blender to fullscreen and see if this persists, if it does try to track down this function in your os and disable it or change its hotkey, Doesn’t look like a os panel that I’m familiar with is it possibly a autohotkey script?

One more thing: this appears to be a Linux-only issue. Same key-strokes in the Windows version invokes exactly what I need doing: selecting that edge-loop! Known issue??

Thanks for your reply, Proxe. I maximised Blender to full-screen but the problem persists. I’m running Ubuntu 11.10 32-bit. In Blender, I generally have the left-mouse button doing the selecting: just can’t get my head around the right-mouse doing so. I tried swapping the mouse-button select option back to default just to see if that was the issue, but it doesn’t seem to make any difference. And you’re right: that dialogue appears to be a Ubuntu dialogue, not a Blender one. Now, how to fix that…

Never-mind you posted while I was typing.

Try this link here

or try searching this on google

How to change the shortcut to move windows from Alt

Robynsveil: It’s [Shift][Alt]. Generally, with other cases, when you want Ubuntu to stop overriding the [ALT]-style keys with Desktop Management ones (e.g. if Unity or Gnome uses the same combo for something else) then the solution is to hold the Super key (the one with the Windows logo on it) while you perform the combo.

Thank you Proxe and Lancer. That change you suggested (changing the mouse modifier from <Alt> to <Super>) did it. Blender behaves as expected. Very, very grateful for your help!!