faces not shown ?

i remove many edges on top of these letters but i still have some faces
which are not shown in face mode

can someone explain why ?

and i cannot select these faces
so is this a bug or what?


?? didn’t understand

do you see the letter’s top
there is a face there but it is not even shown with a dot
not certain how to remove it !


The face dot will be in the geometric centre of the face. This may not necessarily be in the area of the visible face.
See the example screenshot, the dot for the top of the W is where the widget is


how come your W letter does have the center on top but lower ?

ok this seems to be an Ngon face
how do you find where the center is
i cannot find it on these letters

is there a better or quicker way to select and ngon face


i tried in verts edge mode to select top
but it looks to me there are more then one face on top
which is strange ?

also someone said to add bevel on letters before doing conversion to mesh
supposed to make it easier to work after !
i’ll test that later one too!


You do no need to worry about the dot in “Opaque Mode”… Just right-click on the face, it works. However, you may encounter problems with some weird Ngons you created. In case you didn’t know, I remind you that Blender doesn’t support Ngons with a hole… like your letters “D” and “O”. You may have to recreate at least 2 edges to cut these Ngons into smaller pieces that Blender can chew. Still, it won’t solve the problem of the middle dot which will still appear at the geometric center of the vertices, wherever it is.

One way to deal with such a situation is to go into “Non-Opaque Mode”, orthographic view. Look at your text sideways and with a bit of precision, you should be able to box-select only the front faces… top faces, whatever.

Note: Non-/Opaque Mode == Limit selection to visible (clipped with depth buffer) Off/On.

these letters were created by blender not me!
then i converted to mesh data
and i began removing some edges on top and i was left with these ngons
and i tried to select these ngon from top but unable to select

i 'll try again in ortho mode and see if it works better

textboolean1.blend (175 KB)
try it yourself

mind you model is only for testing these inward letters with boolean


I’m not surprised that you can’t select any face here… There are none!

I added some colors to make things clear… After having hidden the object “Text”. :smiley:

I just checked and you should have very little problem to bring the green faces back to the top (or the other way around) thanks to vertex snapping.

how come you cannot see the bottom ?
what do you mean by
After having hidden the object “Text”. "

i’ll try to add some color and see if i can get same then you !


There is an object named “Text” that is right in the middle of the work area. I just hid it with [H] so I can see the geometry behind it. ([ALT H] to unhide. You can also click the corresponding eye in the Outliner.) I think that you forgot to clean up the area after the Boolean modifier was applied. Switch to Cycles and you’ll see an object with a brighter material right in the middle of where you’re supposed to work.

And… What bottom? I found no hidden geometry that I might call the bottom. Your part of wrist watch (I guess) is just an open shell in which the object “Text” punched more holes. Did I miss something?

When ever you perform a Boolean operation, always be sure that face normals involved are oriented in the correct direction, or you can get really odd results

ok i found the text ob !
i forgot to remove it after doing the boolean
should have tought about that one !LOL
but i tried to select it and was not able too so that was strange!

now i can see clearly the shape i need

what about the sort of distortion on the watch surface itself around the embeded text
seems to create like artifacts lines

i got to have a very smooth surface to render this or it will show up and wont’ be nice!


i corrected the mesh and added an edge split modifier and now seems to look not bad at all


ok i found the text ob !
i forgot to remove it after doing the boolean
should have tought about that one !LOL
but i tried to select it and was not able too so that was strange!

Nothing strange at all - you edit one object; no other object could be selected - that’s how blender works.

done all the boolean works
and it works like a charm now