Fake flat shading behavior

Hi everyone. :slight_smile:

I was making a sword for a game. (complete newbie if it comes to modeling)

Now the problem is, every 3d object in game is smooth rendered, which is actually not bad for some parts of the sword. Still the blade looks awful and I thought that maybe it is possible to fake the flat shading behavior through normal maps.

Now my question: How? And are there any other best practices to achieve that?
(the sword is low poly)

How it looks now:

How it should look, even with default smooth shading enabled:

you could add extra edge loops with ctrl+R and move the loop closer to the edge you want creased. This however adds extra geometry.
you could also try the Edge Split modifier which will rip the edges of the sword making it sharp.

there is no right or wrong answer to creasing edges and it all depends on what trade-offs you’re will to make.

in any case, using a game engine that doesn’t support flat shading is very limiting in my opinion.

Or just go into edit mode, select the flat faces and from the left toolbar (shading/UVs tab), select faces > Flat. That way everything is smoothed except the desired faces without the need for additional vertices.

Ok it seems I used some other tools wrong guys… (so sorry :o)

Still BiggR’s suggestion optimized my modeling workflow, thanks for that.:yes: