FBX import problem. PBR texture mess

Hi community!

I faced a problem. Maybe someone can explain what I do wrong. Maybe I didn’t notice some settings or another little thing.

Story:

  • I made a sculpting Hi-poly model (In the end it was without animation or rigging).

  • Then I made low-poly in Retopoflow. Added seams for UV. And made smart UV project.

  • After that I exported Hi-poly (through FBX export build-in tool) model to the Substance painter, colored it and exported PBR.

  • I connected PBR to Hi-poly in Blender.

  • With an add-on Simplebake I baked Hi-poly PBR to Low-poly.

PBR on low-poly worked properly. After that I needed to export low-poly model in FBX format with embedded PBR textures (I know how to export with textures: export FBX, choose copy, press embedded).

To check I decided to import the FBX to Blender. Then I got this mess (see image). It was visible only in render mode and material preview. When I changed render mode from Eevee to Cycles. Problem stayed only in material preview mode.

I tried many variations of export settings.
Different Simplebake settings.
Rebaking textures.
Checking my UV (it was only one).
Checking Normals side.

And all times I received the same mess when I import FBX back to Blender.

Moreover, I even imported this FBX to 3ds max, Unity project (in Substance Painter and Zbrush I imported the models without textures). In these all variations I received the model without this problem. The problem was only in preview mode after import.

I googled. Found just one-two users with the same problem.

After two evening of this experiments, I decided to try to import to the Blender with an add-on “Better FBX import”… Hah…and problem disappeared. But a new additional FDM folder appeared.

I’m using Blender not for long time, but I figured out a lot of basic things. Eventually, I want to use models for projects (like Unity or Unreal), maybe sell them on stocks. And I want to make sure this problem does not spoil anything in the future.

It looks like you have alpha blend turned on in you eevee material settings, (and show back faces) if you have no alpha channel change it to none. (Material tab - settings - blend mode)
I think the importer turns it on if you use a png file for the image texture

Edit:
If you are using cycles you will have to swap to eevee to change the eevee settings for viewport, you can switch back to cycles after you have changed them.

1 Like

Thank you for the answer! Changings in blend mode is right.

I worked only in Cycles, therefore I would not think that the problem was in the Eevee menu.
I bake PBR with .jpg setting. Now FBX import is clear.

P.S.
Maybe you can give advice, how right to export FBX for stocks for example. I will need to do file with embedded textures or just to place near in folder?

And .Bmp is this a good choice rather than .png ?

Show screenshots of the shader networks of these imports.

The only problem with .png files is that the can have an alpha channel (you can save .png files without an alpha channel)

The Blender fbx importer checks the images to see if they have an alpha channel (even if it is all set to opaque) and if it does Blender automatically plugs it into the alpha channel of the material and sets the eevee blend mode to alpha blend.

If you use a png that does not have an alpha channel blender will not plug it in, nor set the eevee material to alpha blend mode.

If you want to save your images in .png do so, but make sure you do not save an alpha channel unless you actually want it. This will also reduce the image file size.
I am sure substance painter will give you the option to save png’s without the alpha channel (I do not use substance). If not you can get rid of the alpha channel with Gimp or Photoshop.

As for selling assets, people like to see png files as they “presume” they are uncompressed (although you can compress png files). So it is a good option.

I usually put the image files into a separate texture folder, for fbx is is possible to embed the images but it was not always that way and some software might not be able to retrieve them.
Not all formats can embed images OBJ can not, the OBJ_MTL file only points to them so for obj you will have to make a separate “texture” folder.

Hello! Thank you for your answers!
I got back to this question and made some tests. I want to tell you about the results.
Since I already knew that the reason of the problem was in the PNG alpha, I tried to find what adds alpha to the image.

In Substance Painter I made custom export preset without Alpha. If I connect that PBR to my object and I export FBX, after that import back, I don’t have any problem (therefore the problem is not in Substance).

I tried this problem solution ( https://blenderartists.org/t/fbx-import-how-to-turn-off-import-texture-alpha-to-transparency/1284337). Hah, it works, but, if I understand it correctly, it doesn’t connect alpha (in some situations it is not good).
After that I rolled back the Blender settings and finally, I made two PNG in Photoshop (with alpha and without). I connected them to Blender in node editor and etc. And I got a model without blendmode artefacts.

Besides, I tried different variations of manually saved PNG without alpha. In all situations I got all import FBX without the problem.

At the end I think the cause is in the SimpleBake, because it added an alpha channel to the baked PNG, although I didn`t select any alpha settings check any alpha setting. (Maybe I didn’t see some settings)

Thanks for your suggestions!
Just one quick question.
What is the easy way to check for alpha channel in PNG?