Feature request: Projection Paint as Clone Texture Source

I know this is just another drop in the bucket of feature requests, and maybe I will get pounded for something that is trivial, but I have been trying to work out a solution for my own and I don’t code (yet).

I was wondering if the UV Projection modifier could be enabled to be a clone source for projection painting, allowing the user to easily rotate/pan/scale the source image and then paint the cloned pixels into the intended target image on the object. That way, I could project my image from camera view, rotate my target object, paint what I need where and then scale up or scale down the camera projector to fit the image to the destination on the target.

If this is already possible somehow, I would appreciate somebody enlightening me. I use 2.57b for everything now, and have had no luck with using the uv projection modifier at all. I downloaded the little house blend that is the online example, and have yet to understand how to set up the target object’s materials to have a UV layer yet have no UV texture as in the file.

You can.
You just have to choose a different UV Texture layer for the source image that the one you are painting on.

UVtexture layer panel is in Object Data(Mesh) Properties.

Well, sorta… sorta buggy is what I get. In 2.57, I cannot get the brush to NOT copy based on the 3d cursor location, but in 2.49 I can. It took a few tries to figure out the pattern to getting a layer to project to (white canvas) and an image to paint to(black) and when the cursor is over the mesh plane, the same part of the clone picture that is by the 3d cursor keeps projecting wherever the brush goes. In 2.49, there was an option to turn that off in the modifier, if I remember correctly.

Could be I am inept and should just shut this off and go back to painting clones in gimp. I hate not seeing what is going on in relation to my object though.

Fixed - evidently, I was setting my stencil layer and source layer wrong at first, backwards, and then another issue was that I was hitting ‘apply camera image’ and that set off some weird behavior when i tried scaling and translating my projector. All worked well once I set up those specific texture images to my material and double checked they were set to map to the right uv layers :slight_smile: I will see if there is a way to document it easily or put it up on vimeo later to show the simplest set up. This helps very much, thank you!

Edit: Here is a little video I made to show the basic set up for using the UV Project modifier in conjunction with the Projection Painting in UV Layers.

Bumped - this is solved, but I cannot find the ‘solved’ thread button, maybe a Moderator can mark it. Thank you

i have a question about re-projection

where are those images saved that open in photoshop? and are they deleted when you close them?

yes but in very limited way
if you download this file
http://www.luceri.it/?file_id=8
open with blender 2.55 you can do this

but if you open the file with blender 2.57 you can’t move, rotate or scale the mesh
( i don’t understand why this change)
thanks for attention

but if you open the file with blender 2.57 you can’t move, rotate or scale the mesh
( i don’t understand why this change)

I don’t exactly understand, since I didn’t learn this feature until 2.57b, but If you were using the camera as a projector, then you would not want to rotate the mesh object, you would want to rotate your projector. I will see what I can figure out tonight. Interesting video, but I wonder about the scaling issue - would that be really a good idea with the chance that the scaling became permanent?

I believe those images were still open in Gimp, and it is up to the user to save the changes to the UV mapped texture in the UV Image editor. That is I mean for committing the additions to the iamge base you already have applied as a texture to your mesh. Saving it in Gimp or Photoshop just means you will be able to recall it, right? I need to try it out for real.

@ Gillan -I tried downloading 2.55 and got it to work the way you show, and then tried in 2.57 and cannot. I do not know why, but it was interesting.

I think maybe this could’ve been changed to keep it from breaking something else?

Moderator, please move this to a more appropriate forum- I think this should be in a support forum now, I guess, I had not known the functionality existed at the time…