File corrupted, not able to open it

Somehow I think my hard drive has corrupted one of my blendfiles. I can’t open it, Blender just crashes and that’s it. Is there a way to get it to open the file or repair it?

is the filetype exactly “.blend” or is there something else

it is .blend

One method would be to create a new blend file and then append the objects form the crashed one but that would just be a compromiss solution

Doesn’t work, crashes Blender.

Oh man thats bad! :frowning:
I searched alot for repairing blendfiles but i found nothing useful!
Last chance maybe there is something wrong with blender update it or upload your file so that i can check them

What blender version?
Did you use an updated blender version?

There were incompatibilities in the process of blender going from version 2.49 to 2.58.1.

what about the generated backup-files? They are normaly (since 2.5?) named with extension .blend1 … .blend2 – ?

Hi, I worked on my .blend with 2.49, been a while since the last time. I found a xy.blend1 and opened it with 2.49 and saved it as xy2.blend. Then I tried to open it in 2.5 and everything was fine. Thanks everyone for the support!