File Open? finding folders? networked drives??

Feeling a bit “noobish” but I did my search and can’t find answers, so…
When I start the File>Open dialog, I can navigate to the ‘parent’ and all local drives, but how do I find content on a network drive. Sharing is turned on for all of the drives on the remote station, I use TightVNC to view them and Open and run files on the remote station (it is actually in the room here) without difficulty. I want to be able to use the extra drives for projects and Open .blend files from my local system.
This even got “weirder” after recently installing UbuntuStudio64 and Blender 64 on this station (highly recommend it… my plan is to try and render Big Buck Bunny scenes as a test for an animation project, but it takes lotsa RAM and 64bit OS) and now when I launch the “new” Blender, it only sees the “home” folder on the Ubuntu system, let alone a local drive or folder, and a network drive, forget it.
I am able to run TightVNC on the new UbuntuStudio64 station, view the “remote station” and run programs remotely on it just fine.
Return back to my WinXP32Pro station (dual boot) and try again on the Open>File dialog but I am stuck, can only see local drives and not networked resources. Any bright ideas???
Thank you.

hmmm… Honestly, I dont think that works… You are asking how to navigate to network folders IN blender right? If thats the case, I dont think blender can navigate to anything that isnt located on the computer itself…

Thanks for trying to help. I just checked, and on my WinXP32Pro setup, I can “see” all of the local drives, including a local folder “mapped” that the other stations can also see, but Blender won’t let me go looking at any of the networked stations in my work group. This seems odd as the Big Buck Bunny project all had to be done on a “local” station??? how did they share assets???, carry them around on floppies??? come on Blender experts!!!
Now, when I dual boot into UbuntuStudio64, I can only see the /home/(username) folder and can’t navigate to any!! of the drives on the same local station, let alone a networked resource.
This just seems primitive, I feel like I am missing something… Help??

the problem with your problem is, to me, that I don’t know if you’re a Linux noob or an expert user?! :slight_smile:
Do you know how to “browse” with Blender/Linux? You should click over the “two points” or “P” button, to go up in the “file tree”?!
Are your drives “mounted”…if yes, they’re probably in /mnt/hda(sda or the like) or /media/sda (sr0?) or something like that ?!

Yeah, like OTO said, navigate to the mount point in the root file system. (Go ‘up’ from your home folder). It will be in /mnt or /media.
Don’t know what happens if you are trying to access Linux drives from within Windows though.

The problem seems more systemic, in that Blender and Open Office can not see anything other than the “/home/username” folder. Interestingly enough, when I navigate using the Ubuntu file browser, no problem, sees all of the drives, even sees the networked stations, but clicking the “P” button in Blender or the double arrows below don’t go any where. In Open Office, same issue, so it’s no Blender specific. If I open the file manager in Ubuntu, navigate to another drive, and click on a Open Office document, it opens fine, just can’t go there from inside of programs. I have a question posted on the Ubuntu from also, but my “noobishness” with Linux is definitely showing. Thanks for the help.

Does Blender’s Help => System => system information give any clues?

Maybe you could use this script called I’ve slightly modified it if I remember correctly and it works with 2.46 on windows. You can see it in the Help menu once installed, and it provides you the standard Windows dialog for loading files :slight_smile:


“”" Registration info for Blender menus:
Name: ‘Open .blend’
Blender: 246
Group: ‘Help’
Tooltip: ‘Open .blend files using standard Windows file dialog’



Copyright © 2005-2006 Mariano Hidalgo

This program is free software; you can redistribute it and/or

modify it under the terms of the GNU General Public License

as published by the Free Software Foundation; either version 2

of the License, or (at your option) any later version.

This program is distributed in the hope that it will be useful,

but WITHOUT ANY WARRANTY; without even the implied warranty of


GNU General Public License for more details.

You should have received a copy of the GNU General Public License

along with this program; if not, write to the Free Software Foundation,

Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA.



author = “Mariano Hidalgo AKA uselessdreamer”
url = (“blender”, “elysiun”)
version = “1.0”

bpydoc = “”"
Allows you to open a .blend file using the standard Windows file dialog.

The script recalls your last chosen folder and defaults there. If the
folder no longer exists, it defaults to C:\.

Needs a full Python installation to work (
##modified for Japanese env , by manda[2007.05.20]

import Blender
import os
import sys

import tkFileDialog
import Blender.sys as Bsys
from Blender import Registry

from Tkinter import Tk

get a encoding string (Is this correct?)

file_enc = sys.stdout.encoding

t = Tk()

t.wm_title(“Open Blend”)

d = Registry.GetKey(‘OpenBlend’, True)
if d:
last_folder = d[‘last_folder’].encode(file_enc) # encodings

last_folder = u"C:\\"

if Bsys.exists(last_folder):

f = tkFileDialog.askopenfilename(title=“Open Blend”,filetypes=[(".blend files", “*.blend”)])

if f:
d = {}

d['last_folder'] = Bsys.dirname((f).replace("/","\\"))
Registry.SetKey('OpenBlend', d, True)
if f[-6:] == ".blend":
    g = f.encode(file_enc)    # encodings
    if Bsys.exists(g):
        Draw.PupMenu("Error!%t|Not a .blend file")

Have you tried jjust typing in your directory that you want to browse to in the text-box. e.g. just type “/” into the text-box which reads “/home/…/” and press enter.

As far as i can remember that should work. (i only used blender on ubuntu for a short time a few months ago)

It sounds like your external drives aren’t mounted right some how. I can navigate and open files with Blender that are on a different computer. I am running Puppy Linux and XP on the other computer.

Dual boot environment, WinXPPro32/UbuntuStudio64.
When in the Win space, Blender can “see” and access all of the local drives just fine, but can’t see any of the networked stations drives, even ones that are “mapped” to a letter for common access to all of the stations. Other programs do not have this difficulty. Following the suggestion here, I have been able to “just type in” a drive letter from the networked station and it does come in fine. Thanks for the suggestion
When in the Ubuntu space, different paradigm, I can navigate up to the level where /media is one of the folders, and it contains all of the local drives, but again no networked drives. I had thought to “just type it in” but was not successful as the Linux syntax it different, so just typing in the drive letter isn’t correct. I did try smb…blah, blah. I will check further on the Unbuntu forums.
I just upgraded to 8GBs of RAM so I will want to jump over to Ubuntu and see if I can render some of the Big Buck Bunny scene that were “no go’s” at 4GB.
Thanks to all for the help.

Eliminate all the spaces in the file path on Windows. I wouldn’t rename Documents and Settings but I might try setting up a test folder on the windows machine that has a path name with no spaces and see if you can open a file from Blender on the Ubuntu machine.

sorry to bump an old thread, but i have the same problem and i haven’t found a solution yet.
i am looking for the “smb://”-folders or directories from within blender, but i can’t find any. i have mounted the shared network folder from my windows machine and can browse the files from within nautilus. but no luck with blender. however, in the filebrowser on blender running on my MacbookPro there is an item called “Volumes” and there is the shared network drive. so what am i missing on ubuntu? any suggestions?

ok, sorry, i found out myself. just mounting via nautilus doesn’t work.
just in case someone else with this problem stumbles over this thread:
you have to mount by hand. here’s what you should do: