Filling plastic containers with lotion, soap and liquid? Looks dark and muddy.

I need to fill some plastic containers with lotions, liquids and soaps. For whatever reason, the liquid inside always looks dark and shitty, not bright like it would in real life.

Attached is a photo showing one example. The bottle is on the left, the bottle + lotion is in the middle, and the lotion is on the right. You can see that the middle lotion is dirty/gray looking. Not clean and bright like the right. In real life, it looks totally fine.

Post a larger screenshot of the glass/container nodes.

Hmmmmm, don’t see anything wrong in the nodes. Can u post a packed blend?

Add some emission to the lotion. It is a hack but works nicely.

This is a well known problem with the glass shader.

The best way to deal with it is to use the light path trick.

The glass on the left is the standard glass shader - the one on the right uses the “is shadow ray” function of the light path node to mix between glass and transparent. As you can see - the liquid in the right glass is much brighter.


I may be wrong but the glass container looks like not having any thickness, if it’s so then the object behaves as it was solid glass, hence the excessive absorption.

paolo

go to lightpath and click full globalillumination

There is no glass shader in the nodes (post #3), he is mixing transparent with glossy using facing, and no refraction.

Quite a few lotions and soaps will glow under UV light, so to our eyes they don’t quite keep with most conventions of preserving light energy, try using an add shader or two when you make the node network to simulate this.

I made a quick recreation of the “glass” nodes and it should work just fine as he has them, what could cause the darkening is if there is not 0% alpha in the image, if there was about 50% alpha it would produce that darkening.


Anyone know how to fix this? These product renders are going in our catalogs and online store and they need to be as accurate as possible when finished.

Did you even read the posts?

there have been multiple suggestions and you need to address them each. And posting the packed blend is best way for a definite answer, as mentioned before. Which you haven’t even bothered to provide or answer why not.

The fact remains that the setup you have is pretty rudimentary and if these are for stills you should really use a glass shader with thickness.

Yes, I’ve went through and tried the suggestions. This is a new problem, it has been working fine for me for the last few months. I have no idea why it’s doing this now. Glass doesn’t work either, it comes out like black.(https://puu.sh/qPk7V/d41d7c0d64.png)

And yes, these are stills but I don’t want the refraction from the glass shader. Also, glass shader makes everything muddy, never true transparent. (https://puu.sh/qPkgk/399ec04914.png Which is why I started going with the glossy/transparent set up.

Here is the lightpath hack: https://puu.sh/qPkl6/5a9b6e4ff8.png.

I tried the emission thing aswell and it makes the lotion completely too bright. I don’t know what the issue is, here is a render I did literally yesterday. Came out fine. https://puu.sh/qPktG/d443879897.png.

Nothing has changed that I know of.

EDIT: SOLVED.

I figured it out. It was from not having enough bounces in my light path settings. I upped diffuse and glossy bounces both to 5. It’s now making all of the shadows nice and clean on everything. Thank you all for suggestions. Hope this answer helps anyone who may need it in the future.

Well thank you for addressing the posts, and the reason for single sided glass. I’m glad you figured it out, and posted the solution for future issues. Good luck.

I was reading through the posts and was about to share an old file of mine which was working fine for quick glass and/or plastic, but when I opened it in the last version of Blender the result is way too dark on the inside. Even when setting the bounces high (12), it still looks weird and I dare to say noisier than previous builds. Could it be a bug from recent versions? Or something to do with the addition of the Multiscatter GGX?

What version are you using?

I’ll have to look into it with more detail later, but anyway thank you for bringing my attention into it. It seems that recent Cycles developments have changed some things that used to work just fine before. :slight_smile:

I’m pretty sure it’s a new thing. I updated blender and this started happening. Change your light path settings from direct light to full global illumination and see if that works

Nope, it just takes longer to render :confused: