Final Render has issues with Normals Calculated Inside [Eevee]

I have a simple scene with a big cube with Normals shaded inside to act as wall.While the render appears fine in viewport but the final render considers the walls shaded outside.
See the attached screenshots for idea…
PS I am using latest build of blender 2.8


Just for the sake of it, the latest March 22 one ?

As far as I know, Eevee and Cycles renders backface. So, you can try this kind of material setup to make backface transparent:

Renders the same as viewport:
image

Just make sure you choose one of the Alpha blend modes for Eevee:
image

1 Like

@Ishaan_1516 Yes it is March 22 version…
@filibis Thanks will try that…

I just noticed that only in layout tab, the viewport supports backface culling…
In other tabs such as shading or modelling, the editing of Mesh Normals has no effect!!!
For now I solved the problem by deleting the occluding faces but I will look into material setup suggested by @filibis

I was asking because I to faxed the same problem with today’s build. I hope they fix it in tomorrow’s build.

You can enable/disable backface culling for each tab independently:
backface_culling

@Ishaan_1516 Ohh I see… I hope they fix it up
@filibis Thanks for the material pointer… it works as expected!!
PS Thanks for the backface culling tip!