Fire will play, but not render - Blender 2.8

Hiya, first post here. I’m pretty adjusted to 2.8 by now, but this is my first go with fire. Has anyone else been having issues getting their fire or smoke to render? Mine plays correctly in solid mode and I can the see the flames, but when I switch to LookDev or Render, nothing shows up. I’ve tried multiple tutorials, a few different node setups, and nothing seems to fix it. Volumetrics are on as well.

I’ve seen a few other threads about this with similar issues, but no concrete solutions, and any suggestions I’ve come across have been attempted on the file below with no luck. I feel like a fool.

If anyone has had the same issues and can offer a solution, I’d be forever thankful. The last node setup I tried is in there, but the emission is not connected to the mix shader. This setup just filled my domain with light, but it is the first to make something appear in LookDev and Render.

Here’s the file

Blender 2.8 (May 2019) on OS 10.12.6

1 Like

Make sure your fire is set up something like this.


YES! This worked beautifully!! Thank you so much!!!

1 Like

Hello, at first I had the same problem of the fire not rendering but now with the nodes it is
But it add a kind of blocky smock
Capture feu bug

my set: