Fix double edges

See my attachment. There are actually 2 boxes overlap each other but they’re not overlap at exactly the same positon. I slided one of the box a bit. So there are edges which are overlap each other , but the vertices not overlapping. How can i clean up the edges ? or let say to remove double edges maybe? so i can keep this shape but having clean edge. Is there an ‘auto’ way to do it rather than manual edit ? since there’s no vertex overlapping , the ‘remove double’ function can’t be used.

I don’t want to create anything, i know this topology can be done using edgeloop, but i’m just curious if i can ‘heal’ this up.

Assuming you want it to become one, go to wireframe, select the relevant points in the middle, set pivot to median point, scale on y axis 0. then remove doubles. Without the blend file, have to guess a bit as to the actual intent and geometry.

1 Like

Sure it can. Remove doubles merges selected vertices that are within set distance apart.

1 Like

If he duplicated two cubes in Edit Mode, there’s still the face in middle to be removed after the Remove Double.

Check the mesh with Subdivision Surface.

Indeed, the middle face would need ot be removed. Easy, wireframe, box select, delete faces.

1 Like

Thanks a lot, buk that’s not what i’m looking for. Do not change the topology or do not move any vertex position. I want the same exact topology. But just want to clean up the overlap edges only. There’s no overlap vertices in this case , so don’t worry about merging vertex. I want to ‘merge’ the overlap edges. I’m looking is there any algorithm to check and do recursively fix the edge into a single batch process or automation.

Sorry, don’t understand, you can’t keep the same topology AND clear overlapping edges. If edges are overlapping and need to be merged, by inference, points need to be moved. I am starting to suspect that what you actually want is an elongated cube with two cuts in the middle. Attached is a simple blend file, layer two has what I suspect you have. Layer 3 is a single cube, scaled on the X axis with 2 cuts applied using Ctrl+R
Is this what you are actually after? Or do you still want the internal face as per layer 2, (don’t know why you would mind you). untitled.blend (1.4 MB)

I think the closest thing that you can do in blender to automatically join two objects is to use the Boolean modifier. This is far from something that keeps the topology as is though. You could try setting a boolean modifier to union mode, then using the remesh modifier, but that completely changes your topology.

You’d have to make new loopcuts on each cube inside the object, then merge the verts.

I had the same issue . All I can say keep your mesh simple and fix double edges before You apply subdivision, solidify. It works with certain level of complexity of the object .