Fix for ATI Radeons with OGL and Blender

As reported by ElBarto at, there’s a new alternative solution for problematic ati video cards. The site has third party drivers for all Radeon cards. The drivers work. Well. They’ve fixed fuzzy menus, fixed ElBarto’s black icon issues and they’ve also fixed a problem I was having with the new icons in the Orange brach where the icons would show garbled images that were unrecognizeable and unreadable. I’m not sure about slow down, since I don’t have the problem, but another nice feature of the Omega driver is they are more efficient and faster. On a slow radeon mobility notebook the performance has been markedly improved.

A pointer to these drivers in an official location might be a good idea. They seem to be very stable, they’ve been around for quite a while, and the ATI problems don’t seem to be going away, as evidenced by the garbled icons in the Orange build here on my pc.

I would definitely recomend giving them a try, they’ve shown to have very good performance so far on the machines here.

  1. heh. Just found another good reason to smile. Default ATI driver will allow the image in the render window to be overwritten by other applications and then the partially rendered image will be lost until blender is finished and refreshes the view. The new Omega driver retains the image. That means you can start a render, go to your web browser and tool around for a while then go back to the render window and see how things are going. Been missing that for a while. Amazing how much difference real software makes.

Still not certain about realtime framerates, seem kind of slugish. How could that be tested. Don’t really care right now. Render window is back online. :slight_smile:

the image gets lost on Nvidia cards too. gotta wait till the end.

infact i don’t think it has ever really updated on any of my computers.


For a while there you could click in the render window while rendering and see that kind of checkered triangle display. If you stop a render in the middle you can still see that. Something to do with depth or angle or something . . .

A side note in the comit logs a while ago stated that there were problems caused by retaining the display while rendering so it was disconected. [edit] So yah, have to wonder how the Omega guy is doing that.

Hi, I just downloaded the new build (Computer blew up a week ago :P)
and I got the fuzzy menu problem. I’m using a Radeon X800XL, and if you go into the catalyst control menu, and turn the bar towards performance and not quality, then it will not be fuzzy. I don’t know if this works with other cards though…

turning off antialiasing [one of the settings controlled by that bar] fixes the menu problem


I only can recommend the Omega Drivers, huh Blender make such a fun and speedup that i have Last time with 2.36.

Read my Post at for a easy installation (struggeled first time because MultiRes did a restart without full installed drivers).

This doesn’t work with the card on the machine here. The fuzzy is there without the anitaliasing and if the antialiasing is turned on the screen has an infinte reflection thing going; kind of like pointing a camera at a monitor. That’s with a recent, last couple of months or so, ati update. Difficult to say. Omega drivers are still operating flawlessy though. Very glad to have them.

Ya, my anti-ailising (sp?) was turned off originally, but it was still fuzzy. Then I did what I said and turned the bar all the way towards performance. No more fuzzy, Blender is working perfectly, and no need for 3rd party drivers. In fact I just made a render with no probs.

There it is. (Sorry, I just had to post it :stuck_out_tongue: )