Flame/Smoke not rendering in Eevee or Cycles

Any idea what’s going on here? I’ve been trying to get this portal effect to render for a few hours now. It’s baked out, it renders in both Cycles and Eevee in the viewport, but it’s completely invisible in final renders in both, and won’t even show up in “Render in viewport” mode! I’ve tried raising density, emission, everything I can think of, but no luck. Any suggestions much appreciated!!

Have you tried switching to CPU? I’ve had lots of problems with volumetrics and GPU lately.

I believe it is because of the transparent background, which surprisingly keeps alpha=0 when encountering volume shaders one. See here for more explanation:

Thanks so much for the reply! I sorta half figured it out late last night when I realized transparency was somehow involved. I ended up turning the background to black and using a luminance key in the compositor to extract what I needed. Then I collapsed into bed before writing back here. This info is really useful, though. Thanks a lot!!