FLIP Fluids Addon: A liquid fluid simulation tool for Blender

Hello,

Looking for advices…

I have some struggle acheving the bow wake in the reference photos. it seem like it stabilize into 2 distinctive V shape wave unrealisticaly far away from the forward the bow and those wave extend more than i would like to the side of the ship (in contrary of the reference photo) .

Ship lenght = 65ft / 19.8m
Ship width = 24 ft / 7.2m
Ship speed = 10 knots / 5 m/s

Domain info
Domain size = 140x60x4
voxel size = 15 cm
Everything else domain related is default. (except CFL number = 15)

The inverse outflow is to isolate the part that i need and an inflow provide a even level.

*Sorry for the quality can only post 1 photo as new user.

i tried many other set up and it always lead to the same kind result. I varied the speed (in the realm of reality for this vessel 4-12 knots (2-6 m/s)) and the water level , the resolution, flip/pic ratio, obstacle friction, domain size. I don’t know what to try now and would glady appreciate any advice.

Hi, from the image it looks like hull of the ship is poking through the bottom of the domain. This is okay for the simulator, but may be causing the wake ahead of the ship as well as the wide spread.

My first guess at an improvement would be to lower the floor of the domain so that the liquid has a thin layer of free space underneath the hull. If the liquid is not able to flow underneath the hull, it will displace liquid forward as well as push liquid to the side more forcefully, resulting in a wide wake pattern.

Hope this info helps!

I’ll add these relevant topics just in case:

2 Likes

You probably meant “ship” :slight_smile:

4 Likes

Haha, whoops! You’re right.

I guess @RLGUY pointers will solve it, otherwise just increase the boat speed or fluid speed until the V shape is correct, kind of silly but should work if you don’t need consistent/realistic speed with other fore/background objects.

1 Like

Hi. I have been working with a scene for a few days. Yesterday I do not really know what happened, but I stop being able to see the whitewater particles in the render. I do see the wire ico-sphere in the viewport but not in the render. I tried removing the add-on and re-installing it…but that does not seem to affect the scene either. I also tried scaling up the particles, but nothing…

Have you disabled the Persistent data option?
Should be off for moving shapes scenen

O sh…yes that is probably it …Thank you

Something to also try could be to render from the command line using the sidebar command line tools. There is a design issue in Blender which can cause large amounts of geometry not to sync properly between the viewport thread and render thread.

Mmm that was not it

hmmm?!,

maybe scale them up!
or use a Custom shape .

Thank you for the instructions :slight_smile:

The render I get when I do it via the command line tools is not exactly the frame I want. I set my timeline to be from 75 to 75 (75 the frame I want). But it gives me a different frame. I might be missing where to set the frame I want in FLIP. Still, I can not see any particles:

do you render with MotionBlur
that would at least explain the offset viewport/rendering.

and jump to start and then frame 75 to possibly refresh the settings does not change anything?

I will try, but I think I tried that already.

Is it possible to use motion blur ? No I did not use it

Hello,

found that in the wiki of the github page ;

1 Like

thanks for the advices @RLGUY @lucky

it is getting better, tried the lower fluid bottom.

4 Likes

It seems the water is moving, not the boat. But water looks water.

This is great I will try it out. Thank you

Ok, I am not sure why now it worked out again. So I finally could render the whitewater particles. Unfortunately, I am not sure what did I do to get them back. Thank you for your help.

1 Like