Flipping keyframe produce weird poses

Hello, I’m fairly new to Blender and this is my first Character I have actually rigged. I followed a bunch of tutorials to get here and have tried to work as clean as possible when setting up the armature, but now, when I try to flip a pose (for a walk cycle for instance), the bones don’t position as I would expect them to. Here I pull the left arm down on a IKBone I connected the arm with. The fingers have IKChains too and are currently parented to that IKBone, which I just now found out to be unneccessery and I have to correct that, but the point is, when I copy the keyframe with that handy button on the bottom right and paste it flipped to the other side, neither position nor rotation match the original pose.

Now I did invest some time researching and came to the point where to recalculate the rotation with Ctrl-N in Editmode, but none of the axis worked. Maybe I didn’t do it right, because I have to admit I have some trouble wrapping my head around animation and stuff. I would really appreciate any help I could get from here, for I’m really at the end of what I can do…


Did you make sure all of the bones that you moved on the first side were selected before you hit copy and paste?

This used to happen to me when I first started using this feature. You’ll probably find that your bones are not oriented in the same direction. To fix this select the Armature and go to the object panel (figure icon) and under display turn on Axis. For the bones that are incorrectly oriented go into edit mode and use the roll setting on the transform panel. For example you might want all the z-axis pointing up and in your case you’ll find that one side of the body is not pointing up. Once you’ve solved this you’ll also find storing and loading poses with Shift-L and crt-L a great time saver.

@artigliphics: I tried all variants of selecting, still with no effect on the outcome. But I’ll keep it in mind for the future, thanks!

@j.mation: Thanks, this could help me alot. I turned on the axis and found out none of the z-axis are pointing up! O_O So I’ll try and change it everywhere and report back the result. Thank you very very much!!!

OMG you saved my sanity. Thank you very very much!