fluid bake stops after one frame

I have been having a problem with a fluid simulation stopping after baking only a single frame. This is not my first sim, but I am not an expert by any means. I am running my own build of 2.47 (with openmp) on Ubuntu 8.04 although I have also tried with the standard build and seen the same thing. It shouldn’t be a RAM issue since I have 8GB and am only trying to do a resolution of ~100. There is no error message, it just bakes a single frame (fluid domain changes to initial fluid volume) and stops. If I hit bake again, same thing. Somewhere some settings must have gotten messed up–and I have tried to reimport all of the geometry and set things up from scratch and get the same problem.

This simulation does have an IPO-animated rotating object too. Even if I delete the animation (or the entire animated object for that matter) I get the same thing, one frame and stop.

Has anyone seen this?? :eek:

As a side note, it looks like multithreading of fluid sims works but NOT with animated objects too–when I turn on the animated object it goes back to a single thread. Is this the case or has anyone gotten multithreaded fluid sims WITH animated objects?


Is it writing the fluid sim files to a directory it’s got write permission for?

Yes. It writes out the three files for step 0000, two *.bobj files (preview and final) and the final *.bvel file.

Can anyone help?

Try testing it with lower resolution. You might be running out of RAM.