fluid sim fill up?

hey, is there any way I can take a closed mesh such as a box and have it fill with liquid to the very top, and not have any other fluids escape the mesh? I want it so that the mesh won’t be visible until it fills up. Is that possible?

Just set the fluid resolution to high enough and nothing should escape.

my problem isn’t that I have fluids escape. Here, to be more specific, I want some letters collapse into fluids and have those fluids fall and then fill up a shape that is below those letters. what would you suggest? have a cone that comes out of the mesh I want filled and have that cone surround the text?

I would make the letters “inflow” in the fluid sim tab. Also, set it to “int shell”

ok, thanks, I almost got it.
I can get mostly everthing filled, but what if the object being filled is sort of complex. when I fill the mesh up, only a cube-shape is filled, and the places where it dips into the mesh and where it sticks out of the mesh aren’t affected at all by the fluid. any suggestions?

Me to and for a good twist in it you should mak the fluid change colors.
Send ne the results please.

I think I got it now, I need to set the resolution higher in the bake options to have the fluids do better, right? anyway, it’ll be a while considering that during the bake it’s at -1 / 100.
I set the resolution down to 100 so now it’s 4/100
(i wish i had a supercomputer and not some compaq with 30 GB)

before I go and wait the rest of the week for it to finish, I need to ask,
does anyone know how to have the fluids fill in the exact domain without bumping up the resolution too high so that it won’t take forever to complete?

A rez of 150-175 usually works for me…, and only takes about 10min-1hr…

I was changing settings on my computer for better performance for my fluid sim (which had been running all day and is now at 10/120) when I deleted a few programs not related to blender, I went back to blender and it went berzerk!:eek: It has a whole bunch of light/medium blue lines running vertical and then it flashes once every ten seconds or so and then it has a background of many previous programs such as photoshop and stuff! AAAAAAAAAAAAH! PLEASE HELP!

don’t panic. blender doesn’t update the ui while calculating. so blenders ui was overwritten by the other programs that where open meanwhile…

so does that mean that once another frame of the sim is calculated that it will go back to normal?
slowly comming out of shock

Yes, it will be fine once blender updates

It finished. what happend is sort of bad and what happened was that it was at like 18/120 and then in about one minute it completed. THe first 18 frames were “normal” but then after that, the next set is what it should have been 30 seconds in the sim. Then, it changes again, jumping to the end. I restarted it and it’s been a good hour that it has been on the 9th frame. does anyone know how to bake it faster but have a higher resolution?

what i would do is decrease the preview resolution to 1 and just rely on the final resolution. This SHOULD increase the performance. (makesure you select ‘final’ under the view property though)

also, resize your domain as small as possible.

thank you! wow, I just started and it’s doing great! thanks!