Fluid Sim Freezes?

I’m messing around with blender fluid simulations, and I’ve come across a weird problem. I baked the fluid simulation, and everything was fine, but if I close out blender and reopen it up, the fluid simulation freezes after a certain number of frames. I don’t know really how to describe this, but here is a video:

It is not supposed to just stop running at the end, it is supposed to continue on. All of the fluid bake files are still in place, and you can see they vary over time, so I would assume the fluid simulation should be varying over time (bake files mirrored here: http://li39-146.members.linode.com/~endeavormac/files/fluidbake/ )

I am working on a process to automate the distribution of fluid simulation renders across different machines, and this problem is currently the biggest obstacle, and one that I can’t seem to work around.

When you say that the baked files change in time do you mean their size? But the date of creation, are they correct according to the last simulation time?

Have you checked the start and end timeline?

Anyway, can you give us more details on this distributed simulation you are creating?

It looks to me that it stops at 10 seconds. 250 frames at 25 fps is ten seocnds. Did you extend your frame count in the Bake TAB? The default bake length is 250 frames.

Sorry, it took two days for this post to pass the moderation queue and I thought for some reason it had been dropped. I have since deleted the fluidbake files in preparation for the next fluid sim. If I can reproduce the results again, I’ll be sure to leave the files up in this post.
The original blender file is here: http://li39-146.members.linode.com/~endeavormac/files/d30467c6.blend

In response to extending the frame count the Bake TAB, I have no idea what you are referring to. It baked files out to 520 frames, and originally I could play the fluid sim out to 520 frames. However, after closing out blender and reopening, I could only get to 250. You can set the “time” of the fluid animation, IE it will start at 0 “seconds” and render to n "seconds, but this time is spread over the start and end frame of the animation, which I had set to start at 0 and end at 520.

I’m doing another fluid sim now. The bake files total 16gb, so if I can reproduce the problem, I’ll post the information and won’t delete the fluid bake files

And now I’ve reproduced the problem. It was working fine, I rendered a completely different fluid sim, this time at a much higher resolution with more particles, and generated 16gb of fluidsim bake files.

This time, blender goes to frame 55, and then the fluid simulation refuses to play.

This worked great before i closed blender, but now the fluid simulation dies after frame 55.
If anyone else wants to bake a high-quality fluid sim, close out blender, and then re-open it and tell me if they can reproduce this issue?

A friend of mine baked the fluid sim files seperately on his machine, and he is reproducing the issue.
[edit]Ok, scratch that, his fluid sim plays fine up to frame 390. He baked the exact same file. The difference is 32bit windows and 64bit linux.[/edit]

Blender doesn’t crash, runs this bake all the way through, and plays fine… but when i load the fluid sim back up there are issues…?


Ok, this has to be a bug.

Start up a quick fluid sim, bake the files. After it’s done baking, go to a random frame in your animation, and then change the path of the fluid bake files. Save the blender file, and then close it out. Open the blender file back up, and then set the path to the fluid bake files so it points back to the correct path. You should notice that all the frames AFTER where you have set the frame marker (or whatever it’s called), don’t display correctly, but all the frames before do. If you save the file, and reopen, problem persists.

You have to have the frame marker set to the last frame when you change the path and save the file.

Can anyone else reproduce that?

Also, upon reviewing this topic, I apologize for replying to myself several times :/.

Hello guys,

I will take a look into this issue :slight_smile:


I had the same issue. I managed to fix it by simply selecting the fluid domain object, deactivating it as a fluid in the physics properties. Then I select it again, reactivate it as a fluid domain object, and point the bake directory to the corresponding directory where the bake files are.

And now it works as it should.

I’ve had this problem too.
My render would start “repeating frames” after frame 6, however I could render single frames after 6 and they would show up fine.
I tried starting at frame 8, which rendered a lot more, up until about frame 260, but then it started “repeating” again. :frowning:

Very annoying. I haven’t played around with bake directories at all, and I don’t think I’ve quite blender, but it still did it :frowning:

Damn it!!! so some obscure bug which is practically unresolvable has ruined my long project forever, now i have to start over… AGAIN.
Please fix this…

The developers don’t normally read this forum, try reporting a bug at http://www.blender.org/development/report-a-bug/.

This is not jet fixed, still in 2.49a, but your way saves my work!!!