Fluid Sim Problems..

Hi all,

Using blender 2.55 r33530 and I’m having a heck of a time getting the fluid sim to work. I’m looking to create a small puddle or lake. I have a mesh with an indentation in it set to ‘obstacle’ and ‘shell’. I duplicated the indented part of the mesh, separated that into a new object, added a top to it to give me the basic shape of what the fluid should be. Created a domain, assigned settings etc. When I set the fluid object to ‘volume’ and bake, the fluid starts to the left (or -x) from where the fluid object is. If I set the fluid to ‘shell’ it starts where the fluid object is, but the fluid stays on top of the fluid object and doesn’t move. I’ve spent some time on this and can’t figure out where I am going wrong.

I can create a domain, 1/2 a sphere with extruded & scaled geometry (think tea cup) and fluid object and get that to work fine, but I can’t figure out why this example isn’t working. Please see attached .blend.

Thanks for any help,


fluidsim1.blend (525 KB)

For all your objects:

  • Remove doubles
  • Recalculate normals
  • Reset scales - Ctrl+A / Scale

Thanks Richard, but no dice… didn’t change a thing… :frowning:


ps If you can get it to work, post up the .blend please…

Just did as I said in my previous post plus increased resolution.


fluidsim2.blend (564 KB)

My apologies Richard, yes your steps worked and to be honest I should have known to do that… :spin:

However it wasn’t until I jumped up the resolution of the sim that it behaved correctly… At the low res I was using, even with your advice, it’s still the same, see attached screenshot. Once the res was boosted up, it works. I wasn’t aware that lower res would affect it as such. Other than a few small experiments, this is my first time really trying to use the fluid sim.

Thanks alot, now if you could solve this other problem…

just joking,


I also changed the viewport from showing the preview res to the final res. I find the default resolutions way too low to really see what the fluid is really doing.