Fluid Simulation Problem

I’m having some trouble with the fluid simulation, I’m trying to create a whirlpool and it works at a resolution of 21 but when I up the resolution to 50, Blender freaks out and my fluid loses it’s top literally. Does anyone have any ideas? I have one object spinning in the fluid. Here’s a picture of what’s happening.


What happens when you render it? It looks to me like gravity taking hold of your fluid, which always happens.

That’s how it renders also and it’s not just gravity if you look closer there is not top to the cube shaped amount of fluid. And it’s empty.

I just set up a similar scene to yours and got the same result.

Try reducing the amount of fluid. I set up a cube for the domain, and another for the fluid; when I brought the top vertices in the fluid cube down, effectively “shrinking” the water, I got a more normal result. It may be that there’s too much fluid in your sim.

That was messed up. I changed the size by .95 and it works fine so far. That’s kinda annoying that a change that small made it work when I tried everything else.

Nevermind, it stopped working again.

I wish I could help you more. This issue has been difficult for me to recreate. The only times when I have a disappearing surface are the times when I have “too much” fluid in the sim. Unfortunately, volume calculations are tricky, because the fluid never completely fills the domain, so I can’t give you any guidelines regarding how much fluid is too much. Suffice it to say, the couple of times I ran into this in my testing today, I fixed it by reducing the amount of fluid I was working with, or by making the domain object taller. Maybe someone who knows more about this than I do could help you more.